[arch-general] Silent boot with systemd and sd-encrypt initcpio hooks

Sefa Eyeoglu sefa at mailbox.org
Sun Oct 27 14:37:25 UTC 2019

Hey there,

I recently switched my mkinitcpio configs over to use systemd hooks instead of 
the default ones. 

Currently my hooks like like the following: 

HOOKS=(base systemd autodetect modconf block keyboard sd-vconsole sd-encrypt 
filesystems fsck)

As you can see, I have an encrypted root partition. Before switching to 
systemd hooks, after typing the decryption password on boot there was no 
additional output. Now there is always the full systemd log where it says 
"Starting [unit]..." and so on.

Kernel parameters:

rd.luks.name=[long uuid]=cryptroot rd.luks.options=timeout=20 root=/dev/
mapper/cryptroot rw quiet loglevel=3 rd.systemd.show_status=false 
rd.udev.log_priority=3 i915.fastboot=1

I tried rearranging the parameters like putting "quiet loglevel=3 
rd.systemd.show_status=false rd.udev.log_priority=3" before anything else and 
even tried putting it before AND after the rd.luks.* parameters with no 
success. Is this a bug with the systemd hooks or am I doing something wrong 

Thanks for looking into this issue! :D

Kind regards

Sefa Eyeoglu
Free Software Developer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: This is a digitally signed message part.
URL: <https://lists.archlinux.org/pipermail/arch-general/attachments/20191027/1003e6fc/attachment.sig>

More information about the arch-general mailing list