[arch-general] sudo: setrlimit(RLIMIT_CORE): Operation not permitted

Cem Keylan ml at ckyln.com
Thu Oct 31 08:48:42 UTC 2019

Hello list,

I have a script for bootstrapping Arch and I test it on the
archlinux/base docker container everytime before I make a
release in order to make sure everything runs fine.

Yesterday, I have run the script on the container, and it started
throwing an error everytime my script called "sudo". It doesn't break
the functionality of sudo, so it runs the called function with root

The error is,

"sudo: setrlimit(RLIMIT_CORE): Operation not permitted"

The problem is not related to the script as it gives the same error on
the container when I run sudo myself.

I searched the wiki, the forum, and the internet but couldn't find
a conclusive answer. My laptop is running the latest version of Arch
and I have no issues with sudo. I have similarly updated the container
to the latest version before running the script.

More information about the arch-general mailing list