[arch-general] intel gpu hang

Ralf Mardorf silver.bullet at zoho.com
Wed Jan 6 03:41:36 UTC 2021

On Wed, 2021-01-06 at 03:26 +0330, Muhamad Moghadam wrote:
> Hi Everybody,I have a pc with intel gpu and run it on fedora, but
> intel gpu will be hang with fedora kernel. if i will install arch,
> will my problem be solved?


I can't answer your question. At least I run into trouble with current
Arch Linux kernels, so I stay with 4.19 rt-patched kernels, since later
5.x kernels (with or without the rt-patch) cause issues on my Intel
machine. I don't know when exactly it started. I could use earlier 5.x
kernels. I had no time to take a look what does cause the issues.
However, one issue is, that after booted into a later 5.x kernel for a
while e.g. opening Firefox could make the machine unresponsive for
perhaps minutes, or e.g. running virtualbox doesn't work at all, even
while the kernel modules are available for a vanilla kernel. With the
rt-patch building virtualbox modules doesn't work at all. I've not
tested with the current 5.x kernel. I read Arch bug tracker reports from
people experiencing similar issues, who found out that it is an X driver
issue. Since I can't find a link now, those "similar" issues are
probably fixed.

[rocketmouse at archlinux ~]$ hwinfo --cpu | grep Model | sort -u
  Model: 6.60.3 "Intel(R) Celeron(R) CPU G1840 @ 2.80GHz"
[rocketmouse at archlinux ~]$ hwinfo --gfx | grep Model
  Model: "Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller"
[rocketmouse at archlinux ~]$ hwinfo --memory | grep Size
  Memory Size: 7 GB + 512 MB
[rocketmouse at archlinux ~]$ ulimit
[rocketmouse at archlinux ~]$ sudo dmidecode -t baseboard | grep Base -A2
Base Board Information
	Manufacturer: Gigabyte Technology Co., Ltd.
	Product Name: B85M-D3H
[rocketmouse at archlinux ~]$ sudo dmidecode -t bios | grep -eVendor -eVersion
	Vendor: American Megatrends Inc.
	Version: F15

FWIW the Arch Wiki does mention something i915 related:
Regarding the update date, it's not related to the current issue.
[rocketmouse at archlinux ~]$ grep mesa /var/log/pacman.log | grep \(13 | tail -1
[2017-02-16 21:52] [ALPM] upgraded mesa-libgl (13.0.4-1 -> 17.0.0-1)


More information about the arch-general mailing list