[arch-general] Rescue mode stopped working

David Rosenstrauch darose at darose.net
Mon Jul 26 23:35:14 UTC 2021

I'm not sure what changed, but for some reason I'm no longer able to 
drop into rescue mode on my laptop (i.e. using "systemctl rescue") - or 
to boot directly into single user mode.

When I try either of these, the kernel loads, and then looks like it's 
entering single user mode, prompting me to enter my root password to 
proceed (as it should).  But when I do enter the root password at the 
prompt - or even just press enter - the system quickly displays 
"Reloading system manager configuration", followed by something about 
switching to default target, and then switches into full interactive 
mode complete with graphical login prompt.

I tried downgrading down to several earlier versions of systemd (back to 
248), as well as trying to boot using the LTS kernel in single user 
mode, but I still get the issue.

This behavior has definitely changed very recently (i.e., within a few 
days to a week) as I use single user mode often, and only just noticed 
this today.  I'd file a bug about this but I have no idea what package 
might be at fault.  Any pointers appreciated!



More information about the arch-general mailing list