[arch-ports] node-gyp segfault on node 11.1.0 archlinux32

Matthew Hague matthewhague at zoho.com
Sat Nov 24 17:01:50 UTC 2018


I am currently running into the following problem trying to run

    $ npm install hci-bluetooth-socket

I am told i need to run "node-gyp configure" first, which always 

    $ node-gyp configure
    gyp info it worked if it ends with ok
    gyp info using node-gyp at 3.8.0
    gyp info using node at 11.1.0 | linux | ia32
    gyp http GET https://nodejs.org/download/release/v11.1.0/node-v11.1.0-headers.tar.gz
    gyp http 200 https://nodejs.org/download/release/v11.1.0/node-v11.1.0-headers.tar.gz
    zsh: segmentation fault (core dumped)  node-gyp configure

I have tried with node-gyp 3.7 with the same results.  Has anyone else 
encountered this problem or have ideas how to diagnose/fix?  I am 
currently attempting to install a different version of node.

Here is a bit more information.  It's a bit light, but i'm not sure what 
else to provide!

    $ pacman -Qs node   
    local/node-gyp 3.8.0-1.0
        Node.js native addon build tool
    local/nodejs 11.1.0-1.2
        Evented I/O for V8 javascript

    $ uname -a       
    Linux matteee 4.18.16-arch1-1.0-ARCH #1 SMP PREEMPT Tue Oct 23 20:21:46 CEST 2018 i686 GNU/Linux



More information about the arch-ports mailing list