[arch-proaudio] 4.14.18-rt15 Intel Spectre v2 broken microcode detected

Ralf Mardorf ralf.mardorf at alice-dsl.net
Sun Feb 11 06:16:16 UTC 2018

On Sun, 11 Feb 2018 00:13:18 +0100, Joakim Hernberg wrote:
>On Sat, 10 Feb 2018 19:39:07 +0100
>Ralf Mardorf <ralf.mardorf at alice-dsl.net> wrote:
>> Now that you bump to 4.14.18_rt15-1, too and since I read the diff
>> https://aur.archlinux.org/cgit/aur.git/diff/?h=linux-rt&id=aee56edc0ffc7c315d462ae337f446b7ed8007c5
>> I notice that my config "suffers" from a spectre 2
>> "misconfiguration".
>> [rocketmouse at archlinux ~]$ zgrep
>> is not set  
>It should be enabled, right?  I followed upstream Archlinux on this.

It's still not my domain. My guess is, that I made a mistake, IOW I
think that your config is better than mine. However, when I run make
oldconfig, there only was one item asking me what to do. The default
was "N". I simply pushed enter, insted of "?" and/or googleing. I
should consider to follow Arch upstrem, too. OTOH an unpatched kernel
is not aimed for real-time purposes, so a new feature might have
unwanted impact on DSP load. Actually I prefer using your tarballs to
build my kernels, since you add all those patches. The kernels I build
that aren't based upon you traballs, usually are vanilla kernels + the
rt-patch, but no other patch, let alone the config. Regarding rt and
audio drivers my own configs should be as good as yours, but anything
else of my configs could be fishy.

Thank you for maintaining linux-rt :) and thank you for
the /sys/devices/system/cpu/vulnerabilities/ pointer :).

More information about the arch-proaudio mailing list