[arch-proaudio] Is It Me or Ardour?

Ralf Mardorf ralf.mardorf at alice-dsl.net
Fri Nov 9 15:22:31 UTC 2018


On Fri, 2018-11-09 at 15:50 +0100, Jean-Michaël Celerier wrote:
> though as a french I don't see anything that could indicate any kind
> of relevant error in these logs... it may be better to run it under
> gdb to see where it stops.)

Hi,

yes, but since using gdb requires to rebuild the ardour package [1], I
would first take a look by running 'top', to see if still something is
going on [2].

Regards,
Ralf

[1]
https://wiki.archlinux.org/index.php/Step-by-step_debugging_guide

[2]
Begin forwarded message:

Date: Fri, 9 Nov 2018 15:36:53 +0100
From: Ralf Mardorf
To: arch-proaudio at lists.archlinux.org,
arch-proaudio-owner at lists.archlinux.org, hgn, Dancehall Echo
Subject: Re: [arch-proaudio] Is It Me or Ardour?


First of all, is there a reason that my mails to this list need to pass
moderation?

On Fri, 09 Nov 2018 15:08:39 +0100, hgn wrote:
>Switching the language to English in your terminal will drastically 
>increase the chances of an answer, either here or in the ardour
>forums.    

This would be true, if there would be any relevant messages. It's a
language I don't understand, however, without doubts the OP just gets
the usual information messages and then nothing happens. The content of
those messages is about the open files limit etc., there are no error
messages.

An error message could look like this

ardour: [ERROR]: ControlProtocolManager: cannot load module "/usr/lib/ardour5/surfaces/libardour_wiimote.so" (/usr/lib/libcwiid.so.1: undefined symbol: hci_close_dev)

The first thing I would do, to troubleshoot, would open a second
terminal and take a look if running

  top

does show something. In a third terminal I would start with taking a
look at

  ps aux | grep ardour

Regards,
Ralf

-- 
pacman -Q linux{,-rt{-securityink,-pussytoes,-cornflower,}}|cut -d\  -f2
4.19.arch1-1
4.19_rt1-0
4.18.16_rt9-1
4.18.16_rt8-1
4.18.12_rt7-1


More information about the arch-proaudio mailing list