[arch-projects] [initscripts][RFC] cryptsetup: deprecate old syntax and default to the systemd one

Heiko Baums lists at baums-on-web.de
Sat Jul 28 17:18:10 EDT 2012

Am Sat, 28 Jul 2012 22:45:01 +0200
schrieb Tom Gundersen <teg at jklm.no>:

> I was referring to the crypttab page. As I said, I didn't have the
> chance to double check this myself, but I noticed that your units were
> off, so that would at least be the first thing to check.

And I already answered that I checked it more than twice. Of course, I,
too, can sometimes miss a detail when reading a man page.

> That's the intention. There might of course be regressions, I'm
> looking into that now.

So, it was a bug or at least something that should be fixed if the size
has to be converted from byte to bit.

> Keep your snarky comments to yourself.

Well, that depends. If people don't seem to take me seriously and tell
me to read 3 man pages even if I did it, then people have to live with
such snarky comments. I know those comments didn't come only from you
personally, but some of them did. And I didn't miss that you're on your
phone, so I don't expect you to test and to fix this at once on your

I'm really willing to help and to test. But then this should be kept
serious and factual.

Nevertheless, I tried to convert the size from byte to bit in the new

From the old syntax:
home		/dev/sdaX		/dev/usbkey:15675879:1024

To the new syntax:
home         /dev/sdaX        /dev/usbkey

Still the same error:

Unlocking home
Failed to activate: Invalid argument
Unlocking of home failed.

So the units are not the reason.


More information about the arch-projects mailing list