[arch-releng] Bittorrent with webseeds

Dieter Plaetinck dieter at plaetinck.be
Sat Jan 24 14:52:46 EST 2009

On Sat, 24 Jan 2009 17:57:19 +0100
Gerhard Brauer <gerbra at archlinux.de> wrote:

> Am Sat, 24 Jan 2009 11:20:03 +0100
> schrieb Gerhard Brauer <gerbra at archlinux.de>:
> > Am Fri, 23 Jan 2009 17:28:02 -0600
> > schrieb Aaron Griffin <aaronmgriffin at gmail.com>:
> > 
> > > Gerhard, could you possibly build some of the ISOs? Is everything
> > > in order? I am adding dmraid to the package list right now.
> > > 
> > > I won't be home until late tonight (now + 6 or 7 hours), and I can
> > > get to building then - I'm actually building the grub based ISOs
> > > now (yay ssh and screen).
> > 
> > Yes, sure. I build today (Sat.) all i686 ISOs and upload them to 
> > http://users.archlinux.de/~gerbra/iso/
> > I try also building the i686 USB images (never tried this). SO you
> > could pick up what you need.
> > I start building the isolinux images when you say: i build grub
> > ISOs.
> OK, I've built the i686 ISOs and uploaded them.
> From my view this could be the final ISOs (dmraid is added, newest
> mkinitcpio is on board, they all boot...)

Hey uhm.. I've just discovered a quite big bug in aif:  it used the live
pacman at some point instead of the one for the target system without
doing pacman -Sy first, while pacman -Sy is done (only) for the target

Two options:
1) we don't rebuild and keep the isos like they are.  aif will break
during installation in all cases, unless the user intervenes manually
and does a "pacman -Sy" in a terminal somewhere between configuring the
network and selecting the packages.  (note that you need a working
internet connection during installation)
2) i've fixed the code, retagged it (2009.01.24) and retested. it
works now.  if ok for you guys: Aaron, can you update your PKGBUILD/the
package and can we rebuild the isos? i can even build the iso's and
upload them if you want (though I'll need an ftp account somewhere then)

Pierre said that he can't fix the torrents until monday evening anyway
so I guess we can pick option 2.

There's a quite peculiar reason this issue pops up so late btw:
I've always been working and testing with an install cd on which I
installed git and fakeroot myself (pacman -Sy git fakeroot) so I had a
synced database. now is the first time I am testing with an installcd
that doesn't have a synced database. :o


> I have not built the USB images (cause the stopper FS#12896), but I've
> uploaded a test image for USB which probably have fixed this problem.
> Myself could not test this.
> http://users.archlinux.de/~gerbra/iso/test-usb/archlinux-2009.01-1-ftp-i686.img
> http://users.archlinux.de/~gerbra/iso/test-usb/md5sum.txt
> I also put these links to the bugreport, so that reporting users could
> test them.
> Gerhard

More information about the arch-releng mailing list