[arch-releng] Beta2 ISOs and final release

Gerardo Exequiel Pozzi vmlinuz386 at yahoo.com.ar
Tue Jan 27 18:28:19 EST 2009

Aaron Griffin wrote:
> On Tue, Jan 27, 2009 at 4:25 PM, Gerardo Exequiel Pozzi
> <vmlinuz386 at yahoo.com.ar> wrote:
>> Gerardo Exequiel Pozzi wrote:
>>> Aaron Griffin wrote:
>>>> Road Map:
>>>>    http://bugs.archlinux.org/roadmap/proj6
>>>> Bugs fixed in Beta2:
>>>>    http://bugs.archlinux.org/task/12936
>>>>    http://bugs.archlinux.org/task/12896 with rootdelay=X specified
>>>>    http://bugs.archlinux.org/task/11408 isolinux fallback ISOs
>>>>    http://bugs.archlinux.org/task/11152
>>>> Bugs fixed in git, not on an ISO:
>>>>    http://bugs.archlinux.org/task/12896 (dupe, above) - with usbdelay
>>>> instead of rootdelay
>>>>    http://bugs.archlinux.org/task/12944
>>>>    http://bugs.archlinux.org/task/12947
>>>> So. Please test the beta2 bugs and issues, so we can close them. I
>>>> want to make sure there's no other installer bugs before I release
>>>> another package and rebuild the ISOs
>>>> If all goes well, I'll build and release the final 2009.01 release on Wed or so.
>>>> Cheers,
>>>> Aaron
>>> Hi,
>>> I booted (virtualbox 2.1.2) the archlinux-2009.01-beta2-core-x86_64.iso
>>> and display these two errors messages at startup:
>>> :: Running Hook [archiso-early]
>>> /init: 9: cannot create /: Is a directory
>>> /init: 9: /etc/modprobe.d/usb-delay: not found
>>> :: Running Hook [udev]
>>> The instalation runs OK, but when installing GRUB, this not installed.
>>> /arch/setup, display that are installed OK but in /tmp/grub.log
>>> The file /mnt/boot/grub/stage1 not read correctly.
>>> I used the same configuration of partitions and filesystems that with i686
>>> sda1 / with EXt3 or EXT4
>>> sda5 /var
>>> sda6 /home
>>> Trying to installing manual with grub-install fail with the same error.
>>> md5sum of the stage1 are OK.
>> BTW: booting with archlinux-2009.01-beta2-core-i686.iso in this machine
>> that installed arch64 and executing:
>> mount /dev/sda1 /mnt
>> grub-install --no-floppy --recheck --root-directory=/mnt /dev/sda
>> works OK, and grub is now installed.
> Is the only difference the --no-floppy switch?
No, the same error appears when trying to reinstall GRUB with the x86_64
iso from the bash prompt with this command.

In resume:
Installing arch64 with /arch/setup grub FAIL (No error message at setup,
it displayed that installed OK)
Opening a root console ALT+F2 and executing "grub-install --no-floppy
--recheck --root-directory=/mnt /dev/sda" FAIL.
Chrooting to /mnt (before with --bind mount proc, sys and dev),
grub-install OK
Reboot, boot again x86_64 iso, logging as root, mounting sda1, executing
the grub-install then FAIL.
Reboot, boot i686 iso, logging as root, mounting sda1, executing the
grub-install then OK

I have not tested on a real machine, only in virtualbox 2.1.2, maybe an
issue with it, it is running at 32 bits host system, i will reboot on
arch64 and retry installing grub at vbox.

Gerardo Exequiel Pozzi ( djgera )
KeyID: 0x1B8C330D
Key fingerprint = 0CAA D5D4 CD85 4434 A219  76ED 39AB 221B 1B8C 330D

More information about the arch-releng mailing list