[aur-general] changing the status of the maintainer field

Allan McRae allan at archlinux.org
Fri May 22 09:06:50 EDT 2009

Andrei Thorp wrote:
> Yeah, can we get back to Abhishek's topic please?
> I think I agree with his thinking:
>  - Make the maintainer a proper singular bash variable string
>  - Make the contributors a praper bash array
>  - Let the web interface hold onto its own metadata (I don't think
> anyone wants the web interface editing PKGBUILDs)
>  - Possibly rename maintainer to owner and keep contributors contributors
>    - Or if more clear, rename maintainer to current_maintainer and
> contributors to past_maintainers
> That should clear everything up and prevent further discussion.

I am very much against adding _unnecessary_ fields to PKGBUILDs...   If 
these are not needed by makepkg or pacman, they should only be 
comments.  It is going to take a lot of convincing for me to think 


More information about the aur-general mailing list