[aur-general] LDFLAGS question

bardo ilbardo at gmail.com
Thu Nov 26 02:46:22 EST 2009

2009/11/26 Allan McRae <allan at archlinux.org>:
> I looks like pulse-audio will link to itself and that causes issues with
> --as-needed.  Heimdal had (has?) the same issue so had something like this
> in the PKGBUILD:
> [ -e /usr/lib/libasn1.so ] && echo "## remove old heimdal pkg first ##" &&
> return 1
> If pulse-audio only fails to build when pulse-audio is present, a line like
> that in the PKGBUILD will solve all problems.  Or just a comment at the top
> like the current heimdal package:
> #
> ### Attention: remove old pkg before building - it links against itself! ###
> #

Well, I like these solutions. The problem, though, kind of "solved"
itself. I'm trying to build the brand new 0.9.21, and it also fails in
a chroot with the same error. It doesn't make a lot of sense to me
(the chroot is clean) but the errors are the same, so there must be
some other package that causes this.


More information about the aur-general mailing list