[aur-general] Chmod files in a package

Tony C crt.011 at gmail.com
Fri Dec 31 00:51:10 EST 2010

On 12/30/2010 09:21 PM, Nathan Owens wrote:
> On 12/30/2010 11:17 PM, Tony C wrote:
>> On 12/30/2010 07:42 PM, Nathan Owens wrote:
>>> I am working on package bglibs, it has a installer that installs the
>>> libs and such. Namcap gives that usr/lib/bglibs/lib/... needs 444 or
>>> 644 directories and files need permission set to 644 or 444. I have
>>> tried chmod -R 644 $pkgdir/usr/lib/bglibs/lib and that doesn't work.
>>> Also I have tried:
>>> for dir in $pkgdir/usr/lib/bglibs/lib
>>>     do
>>>         chmod -R 644  $dir
>>>    done
>>> also I have tried:
>>> find $pkgdir/usr/lib/bglibs/lib -type d -exec chmod 644 {}\;
>>> None of the above worked.
>> Directories should typically have a permission of 755 while regular
>> files use 644.You should use 'install' with something like install -m644
>> lib "${pkgdir}"/usr/lib/bglibs/lib which will install the 'lib' file
>> with mode 644 inside the $pkgdir
> I know how to do it by hand, but this package uses an installer,
> atleast builds it. Though it doesn't give you control like configure
> would or such, it is a binary file called bg-installer.
I went here http://untroubled.org/bglibs/ and downloaded the source, ran
'make' && 'make install'. The binary bg-installer that is created after
'make' just hangs when run alone. I would just go ahead and run 'make
install' as instructed on the main site and not worry about the
bg-installer. Perhaps bg-installer gets called when you run 'make install'.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 554 bytes
Desc: OpenPGP digital signature
URL: <http://mailman.archlinux.org/pipermail/aur-general/attachments/20101230/4d571564/attachment.asc>

More information about the aur-general mailing list