[aur-general] [google-talkplugin] How to build an older version of openssl

Denis A. Altoé Falqueto denisfalqueto at gmail.com
Wed Oct 27 11:18:19 EDT 2010

On Wed, Oct 27, 2010 at 1:05 PM, Ionuț Bîru <ibiru at archlinux.org> wrote:
> the PKGBULD has the right dependencies for x86_64
> if [ "${CARCH}" = 'x86_64' ]; then
>    ARCH='amd64'
>    depends=('alsa-utils' 'lib32-gcc-libs>=4.1.1' 'lib32-libstdc++5'
> 'glibc>=2.4' 'lib32-glibc>=2.3.4' 'fontconfig>=2.4.0' 'freetype2>=2.3.5'
> 'libgl' 'glew>=1.5.0' 'glib2>=2.12.0' 'gtk2>=2.12.0' 'libpng12>=1.2.13'
> 'libstdc++5' 'lib32-libx11' 'lib32-libxt' 'lib32-openssl-compatibility'
> 'libv4l' 'lib32-libxfixes' 'lib32-zlib')
>    md5sums=('737283cd4e504dc5d3add2cb057bd273')

I see, but maybe I dndn't made my point clear. I want to make a
lib32-openssl-compatibility, with 32 bits libraries, in my 64 bits
environment. I just wanted to know if I really needed a 32 bits chroot
or if there would be some way to get that just by using gcc-multilib.

I ended up with a solution, using 'linux32 make'. It produced an ELF32
library as I need. But I don't know if it is the best way. I'll
investigate when I have a little time.

A: Because it obfuscates the reading.
Q: Why is top posting so bad?

Denis A. Altoe Falqueto
Linux user #524555

More information about the aur-general mailing list