[aur-general] Delete rEFIt package

Keshav P R the.ridikulus.rat at gmail.com
Fri Mar 16 02:14:24 EDT 2012

On Fri, Mar 16, 2012 at 00:24, Ike Devolder <ike.devolder at gmail.com> wrote:
> Op 15-03-12 17:49, Keshav P R schreef:
>> Hi,
>>      rEFIt[1] has not been updated in over two years by upstream, does
>> not build under linux (any distro) as of now, and is orphaned. I have
>> uploaded refind-x86_64[2] which is a fork of rEFIt. It currently
>> builds under linux and contains bugfixes. Please delete the rEFIt
>> package. Thanks in advance.
>> Regards.
>> Keshav
>> [1] https://aur.archlinux.org/packages.php?ID=14837
>> [2] https://aur.archlinux.org/packages.php?ID=57632
> is it also not building with the patches of the debian tracker ?
> i dont have enough time to search for solutions
> i was trying to build gnu-efi and thatone already failed
> do you have fixes for thatone ?

No. I haven't tried rEFIt with debian patches. But I had never
maintained the package for a start.

About gnu-efi (I maintain it in AUR), it builds perfectly in my system
(tried today, x86_64 with gcc-multilib, although multilib is not
necessary for gnu-efi). Can you post the build log from your system?
Can you delete the existing source dir and try compiling again.

If you want to compile 32-bit gnu-efi libs in 64-bit system (with
multilib), the build system does not support that. You may have to
modify the Makefiles to compile the 32-bit libs in a multilib system
(-m32 and stuff)



More information about the aur-general mailing list