[aur-general] aur upload problems

Doug Newgard scimmia22 at outlook.com
Sat Aug 17 11:46:19 EDT 2013

> Date: Sat, 17 Aug 2013 11:41:22 -0400
> From: d at falconindy.com
> To: aur-general at archlinux.org
> Subject: Re: [aur-general] aur upload problems
> On Sat, Aug 17, 2013 at 05:37:30PM +0200, Rob Til Freedmen wrote:
> > Hi,
> > I've tried uploading to the aur (via web) but got an error:
> > Error - source tarball may not contain nested subdirectories.
> > 
> > aurploader just returns with an unspecified error.
> > 
> > I've looked at the source package and everything looks ok.
> > I've tried an older source package uploaded long time ago
> > and got the same error.
> If you create your tarballs using 'makepkg -S', you shouldn't run into
> such problems.

It's being reported on the bbs, too, including with a tarball made withmakepkg -S. I just tried it myself with a very simple PKGBUILD-onlypackage and makepkg -S, won't let me upload with the same error.Seems to be an AUR bug.

More information about the aur-general mailing list