[aur-general] Can't upload packages to aur now

Simon Hanna simon.hanna at serve-me.info
Sun Aug 9 00:41:09 UTC 2015

On Sat, Aug 08, 2015 at 08:03:02PM -0300, Pablo Lezaeta Reyes wrote:
> 2015-08-08 19:51 GMT-03:00 Marcel Korpel <marcel.korpel at gmail.com>:
> > * Pablo Lezaeta Reyes <prflr88 at gmail.com> (Sat, 8 Aug 2015 19:33:26
> > -0300):
> > > thanks and I hope this will be not repeat; but the lack of info about
> > > the propper config of the config file could has prevented this
> > > because I first check wiki/AUR
> >
> > FYI, it is in the Wiki, on the SSH page to which you are pointed at:
> > https://wiki.archlinux.org/index.php/SSH_keys#Managing_multiple_keys
> >
> yes and not, who will know that the user of aur.archlinux.org need to be
> aur?
the wiki mentions the link to clone which is
$ git clone ssh://aur@aur.archlinux.org/foobar.git
with basic ssh knowledge, and EVERYONE using linux nowadays should now about ssh, 
it should be clear that the user is aur (aur at ...)

> in the ssh they show how configure generically (and I admit aI missread the
> part of the  publickey) but not how need to be for aur specifically.
> but my main issue is solved so thanks y'all (?)
> --
> *Pablo Lezaeta*
Actually you do not have to configure your .ssh/config at all!
If you are using a standard name for your ssh key (sticking to the defaults that ssh-keygen
suggests), you are doing absolutely nothing special with your config. 
The things you set up in the .ssh/config are:
the user - which you used in the clone, so you don't need it
the port - aur uses standard ports
proxy - aur doesnt require a proxy, and you don't seem to need one either
shortcut for the url - which you obviously didn't use either

so you can just delete everything from your config file. 
In fact I couldn't find any mention of .ssh/config in the wiki article of the AUR...

lastly I just tried your version of .ssh/config and the exact error message I got was:

git clone ssh://aur@aur.archlinux.org/foobar.git
Cloning into 'foobar'...
The authenticity of host 'aur.archlinux.org (' can't be established.
ECDSA key fingerprint is SHA256:L71Q91yHwmHPYYkJMDgj0xmUuw16qFOhJbBr1mzsiOI.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'aur.archlinux.org' (ECDSA) to the list of known hosts.
Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

which clearly states you have an issue with your publickey which is an ssh-issue...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: not available
URL: <https://lists.archlinux.org/pipermail/aur-general/attachments/20150809/19e0a75b/attachment.asc>

More information about the aur-general mailing list