[aur-general] perl: symbol lookup error: Util.so: undefined symbol: Perl_xs_apiversion_bootcheck

Ralf Mardorf info.mardorf at rocketmail.com
Thu Jul 9 16:19:50 UTC 2015


has somebody an idea what to do?

I added a comment to https://aur4.archlinux.org/packages/shutter-bzr/ :

"I had 1272-3 from AUR 3 installed and it worked, but seemingly related to pearl upgrades it doesn't work anymore.

After rebuilding from AUR 3 first and then from AUR 4 shutter still doesn't run.

$ shutter
/usr/bin/perl: symbol lookup error: /usr/lib/perl5/vendor_perl/auto/List/Util/Util.so: undefined symbol: Perl_xs_apiversion_bootcheck

Rebuilding perl-scalar-list-utils from AUR 3 git fails. The PKGBUILD isn't provided by AUR 3, AUR 4 or the official repositories.

$ makepkg -s --skipchecksums
==> Making package: perl-scalar-list-utils 1.38-3 (Thu Jul 9 18:02:07 CEST 2015)
==> Extracting sources...
-> Extracting Scalar-List-Utils-1.38.tar.gz with bsdtar
==> Starting build()...
Checking if your kit is complete...
/usr/bin/perl: symbol lookup error: /usr/lib/perl5/vendor_perl/auto/List/Util/Util.so: undefined symbol: Perl_xs_apiversion_bootcheck
==> ERROR: A failure occurred in build().

$ pacman -Qo /usr/lib/perl5/vendor_perl/auto/List/Util/Util.so
/usr/lib/perl5/vendor_perl/auto/List/Util/Util.so is owned by perl-scalar-list-utils 1.38-2"

This seems to be an issue for several apps, but the only recommendation I
found by a web research was the hint to downgrade pearl packages.


More information about the aur-general mailing list