[aur-general] [AUR4] AttributeError: '_pygit2.Tree' object has no attribute 'size'

Florian Bruhin me at the-compiler.org
Mon Jun 8 11:52:09 UTC 2015

* Lukas Fleischer <lfleischer at archlinux.org> [2015-06-08 13:32:26 +0200]:
> On Mon, 08 Jun 2015 at 11:12:36, Florian Bruhin wrote:
> > Hi,
> > 
> > I just tried to upload my first package, and I get this:
> > 
> >     remote: Traceback (most recent call last):
> >     remote:   File "hooks/update", line 194, in <module>
> >     remote:     if repo[treeobj.id].size > 100000:
> >     remote: AttributeError: '_pygit2.Tree' object has no attribute 'size'
> >     remote: error: hook declined to update refs/heads/master
> >     To ssh+git://aur@aur-dev.archlinux.org:22/agendav.git/
> >      ! [remote rejected] aur4/agendav -> master (hook declined)
> > 
> Does your Git repository contain subdirectories? Do you need them?

It shouldn't - I used the import-to-aur4 script to split the repo, and
now I'm trying to push the individual branches it created by hand.

However, I rebased to fix some mistakes I did earlier in my git repo
(like a missing source file). I think I accidentally did something
wrong there, which means the commit-tree/graph actually contained the
earlier (unsplit) repo.

I'll investigate and report back now that I have an idea what's wrong

> Subdirectories were forbidden in AUR 3.5.1 and they are still not
> allowed in Git repositories. I will improve the error message.

Thank you!


http://www.the-compiler.org | me at the-compiler.org (Mail/XMPP)
   GPG: 916E B0C8 FD55 A072 | http://the-compiler.org/pubkey.asc
         I love long mails! | http://email.is-not-s.ms/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <https://lists.archlinux.org/pipermail/aur-general/attachments/20150608/9455f4a7/attachment.asc>

More information about the aur-general mailing list