[aur-general] Upgrade will install package from testing without having testing enabled, it breaks a dependency of a package from AUR

marnout marnout at free.fr
Tue Jun 30 20:39:50 UTC 2020

Le 30/06/2020 à 20:47, Eli Schwartz a écrit :
> On 6/30/20 2:27 PM, marnout wrote:
>> Hi every body,
>> I got a similar error :
> This is not the same error.
>> sudo pacman -Suy
>> :: Synchronisation des bases de données de paquets…
>>   core est à jour
>>   extra est à jour
>>   community est à jour
>> :: Début de la mise à jour complète du système…
>> résolution des dépendances…
>> recherche des conflits entre paquets…
>> :: xorg-fonts-alias-100dpi et xorg-fonts-alias sont en conflit.
>> Supprimer xorg-fonts-alias ? [o/N]
> You selected the default No option here.
>> erreur : un conflit de paquets impossible à résoudre a été détecté
>> erreur : la préparation de la transaction a échoué (conflit de dépendances)
>> :: xorg-fonts-alias-100dpi et xorg-fonts-alias sont en conflit
>> In English it says something like :
>> error: conflicting packages detected unresolvable
>> error: could not prepare transaction (dependency conflict)
>> :: xorg-fonts-alias-100dpi and xorg-fonts-alias are in conflict
> You didn't translate the whole thing. For future notice, if you want to
> describe the output in English you should use
> sudo LC_ALL=C pacman -Syu
> This will print *everything* in English.
>> On my system :
>> pacman -Qs xorg-fonts
>> local/xorg-font-util 1.3.2-2 (xorg-fonts xorg)
>>      X.Org font utilities
>> local/xorg-fonts-100dpi 1.0.3-6 (xorg)
>>      X.org 100dpi fonts
>> local/xorg-fonts-alias 1.0.3-3
>>      X.org font alias files
>> local/xorg-fonts-encodings 1.0.5-2 (xorg-fonts xorg)
>>      X.org font encoding files
>> So xorg-fonts-alias-100dpi is not installed.
> pacman -Syu tried to install it as a brand-new dependency of
> xorg-fonts-100dpi, but in order to do that you need to remove
> xorg-fonts-alias.
> When pacman prompted you to remove xorg-fonts-alias, you said "no".
1. Thanks for the trick "LC_ALL=C"
2. When pacman asked me to remove xorg-fonts-alias, I tried the two 
alternatives the default (Yes) and n for no, but both failed. Perhaps I 
should have explicitly typed "y" and not the dry key "Enter".

I tried again now and everything goes wright.

Thank you very much.


More information about the aur-general mailing list