[pacman-dev] crash in pacman 2.9.8

Roman Kyrylych roman.kyrylych at gmail.com
Wed Oct 25 04:28:18 EDT 2006

OK, I've looked at this machine, where pacman crashed, and found no
corruption in db. Only ghostscript-8.15.3-1.pkg.tar.gz.part and
/tmp/pacman.lck was left.
So, I tried pacman -Su and got exactly the same crash. :-)
Then i run pacman -Svu (still pacman 2.9.8) and
. . .
connecting to archlinux.antesis.org:80
connect: Connection refused
error: cannot connect to archlinux.antesis.org
*** glibc detected *** pacman: double free or corruption (fasttop):
0x0864d6e8 ***
. . .
phrakture, you was right about antesis!
Then I commented archlinux.antesis.org from /etc/pacman.d/{current,extra}
and pacman hanged at connecting to ftp.kegep.tuc.gr:21 but after a
minute or more continued and ended with
error: failed to retrieve some files from current

I'll try to do pacman -Su with pacman3.
Any suggestions how to compile pacman3 so it could work with pacman2

Roman Kyrylych (Роман Кирилич)

More information about the pacman-dev mailing list