[pacman-dev] [PATCH 2/3] libalpm/deps.c : export _alpm_checkdeps (-> alpm_checkdeps).

Xavier shiningxc at gmail.com
Sun Aug 26 04:25:53 EDT 2007

Hm, instead of renaming _alpm_checkdeps to alpm_checkdeps, I wonder if
it wouldn't better to just add a wrapper instead, something like :

alpm_list_t SYMEXPORT *alpm_checkdeps(...) {

or a more specific function for computing the missing dependencies for a given
database :

alpm_list_t SYMEXPORT *alpm_dep_missing(pmdb_t *db) {
  return(_alpm_checkdeps(db, PM_TRANS_TYPE_ADD, alpm_db_getpkgcache(db)))

Any thoughts?

More information about the pacman-dev mailing list