[pacman-dev] [PATCH] PM_DEP_MOD_LT and PM_DEP_MOD_GT depmods added

Travis Willard travis at archlinux.org
Wed Dec 19 11:48:39 EST 2007

On Dec 19, 2007 11:39 AM, Aaron Griffin <aaronmgriffin at gmail.com> wrote:
> On Dec 19, 2007 10:11 AM, Travis Willard <travis at archlinux.org> wrote:
> > I think what he's getting at is he wants a dependency on kernel26
> > version 2.6.x for any x.  Saying depends=(kernel26>=2.6) will match
> > kernel26 for any version >= 2.6, which is not the same thing, because
> > it will match versions 2.7, 2.8, 3.0, and 1000.
> Yeah, and I was under the impression that >=2.6.20 would match any of
> 2.6.20,,, 2.6.20-45, etc

Lol - gmail highlighted as a http:// link to an IP address.  Oh, gmail.

Yes, >=2.6.20 will match those, but it will match _MORE_ than those,
which is the problem (in my mind)

To match specifically 2.6.20.x, you need two entries in the depends:
kernel26>=2.6.20 and kernel26<2.6.21 -- any module we build will not
be compatible, for example, with the next-higher 2.6.x release, and if
we can explicitly say which kernels are allowed in the module's
dependencies, I think that's even better than an open-ended >=2.6.20

> I can't verify right now, but I thought 2.6.20.x was always > 2.6.20 in libalpm

More information about the pacman-dev mailing list