[pacman-dev] Long functions and other minor fixes
seinfeld90 at gmail.com
Tue Jan 2 19:30:43 EST 2007
* Aaron Griffin <aaronmgriffin at gmail.com> [070102 11:31]:
> Yeah. I'm not 100% sure of the rationale in the design doc, but
> according to that writeup, "private" functions should be named _alpm_*
> and "public" functions should be named alpm_*. _However_, if a
> function is entirely internal, as this one is, it should, at the very
> least, be marked static (FTR this prevents gcc from adding an entry to
> the symbol table of the object, which speeds loading ever so slightly
> and gives us a cleaner interface in the long run). Additionally, I
> see no reason to prefer either _alpm_* for purely internal functions,
> unless, of course, you expect a name collision in the future.
I'll keep this in mind next time I open up alpm stuff.
~ Jamie / yankees26
More information about the pacman-dev