[pacman-dev] libarchive, pacman, and libtool-slaying

Dan McGee dpmcgee at gmail.com
Tue Jun 19 18:21:53 EDT 2007

I'm sending this to two lists to see who can offer some insight, as I
tried and failed earlier to get pacman to correctly build with a newer
version of libarchive. I think it may deal with having la files in the
package, but I am not sure so I'll outline what I've tried and know so

Libarchive website:

Current version:

Current Arch Linux version:

As you can see, we are a ways behind. I up-ed the PKGBUILD for
libarchive, rebuilt it without problems (as far as I can tell), and
then pacman -U <new libarchive> and tried to compile pacman. The ldd
output showed that it correctly linked against the new
libarchive.so.2, but it had somehow also linked against
libarchive.so.1. I tried rebuilding libarchive using
options=(!libtool), but that didn't seem to fix anything- it actually
just spit some more errors saying libarchive was missing la files and

OK, long explanation, but it comes down to this:
1. How can we get pacman to compile with libarchive without needing
the la files? libdownload seems to work fine without them, etc.
2. Where is this mysterious link to libarchive.so.1 coming from when
it isn't even present on my system anymore?

This applies to both the most recent CVS release and our GIT tree at


More information about the pacman-dev mailing list