[pacman-dev] CVS update of pacman-lib (24 files)
Aaron Griffin
aaron at archlinux.org
Sat Mar 3 03:14:00 EST 2007
Date: Saturday, March 3, 2007 @ 03:14:00
Author: aaron
Path: /home/cvs-pacman/pacman-lib
Modified: lib/libalpm/add.c (1.121 -> 1.122)
lib/libalpm/alpm.c (1.121 -> 1.122)
lib/libalpm/alpm.h (1.78 -> 1.79)
lib/libalpm/alpm_list.c (1.8 -> 1.9)
lib/libalpm/alpm_list.h (1.6 -> 1.7)
lib/libalpm/be_files.c (1.32 -> 1.33)
lib/libalpm/cache.c (1.36 -> 1.37)
lib/libalpm/cache.h (1.11 -> 1.12)
lib/libalpm/conflict.c (1.42 -> 1.43)
lib/libalpm/db.c (1.63 -> 1.64) lib/libalpm/db.h (1.29 -> 1.30)
lib/libalpm/deps.c (1.73 -> 1.74)
lib/libalpm/package.c (1.81 -> 1.82)
lib/libalpm/package.h (1.33 -> 1.34)
lib/libalpm/provide.c (1.12 -> 1.13)
lib/libalpm/remove.c (1.70 -> 1.71)
lib/libalpm/sync.c (1.106 -> 1.107)
lib/libalpm/sync.h (1.17 -> 1.18)
lib/libalpm/trans.c (1.39 -> 1.40)
lib/libalpm/util.c (1.46 -> 1.47) lib/libalpm/util.h (1.22 -> 1.23)
lib/libalpm/versioncmp.c (1.15 -> 1.16)
src/pacman/trans.c (1.39 -> 1.40) src/pacman/trans.h (1.8 -> 1.9)
Big commit this time:
* Moved entirely to alpm_pkg_get_* accessors, to read data on demand
* Mostly removed the INFRQ_ parameters from outside the be_files backend (making
the backend more extensible in the long run)
* packages created from _alpm_db_scan now have the db and origin set (making
accessors actually work for these packages)
* removed _alpm_db_ensure_pkgcache
* totally revamped the _alpm_checkconflicts function, making it cleaner and
easier to read (and thus fix in the long run) - maintainable code ftw
NOTE: feel free to rename the functions... I couldn't think of anything better
* removed an extra loop in sync.c:find_replacements - no sense in looping over
an entire DB while strcmp'ing the name, when we have get_pkgfromcache
Other:
* package struct "license" -> "licenses"
* Created _alpm_sync_find (duplicate code in some places, find_pkginsync
* Minor const correctness changes along the way
* fixed a couple extra '/' pathing issues (non-issues really)
* removed a duplicate pkg_cmp function
--------------------------+
lib/libalpm/add.c | 60 ++++---
lib/libalpm/alpm.c | 108 ++++++--------
lib/libalpm/alpm.h | 2
lib/libalpm/alpm_list.c | 2
lib/libalpm/alpm_list.h | 2
lib/libalpm/be_files.c | 17 +-
lib/libalpm/cache.c | 82 ++++------
lib/libalpm/cache.h | 4
lib/libalpm/conflict.c | 343 +++++++++++++++++++++++++--------------------
lib/libalpm/db.c | 16 +-
lib/libalpm/db.h | 2
lib/libalpm/deps.c | 124 +++++++---------
lib/libalpm/package.c | 67 +++++---
lib/libalpm/package.h | 2
lib/libalpm/provide.c | 2
lib/libalpm/remove.c | 50 +++---
lib/libalpm/sync.c | 255 +++++++++++++++++----------------
lib/libalpm/sync.h | 3
lib/libalpm/trans.c | 34 ++--
lib/libalpm/util.c | 28 +--
lib/libalpm/util.h | 16 +-
lib/libalpm/versioncmp.c | 8 -
src/pacman/trans.c | 4
src/pacman/trans.h | 4
24 files changed, 657 insertions(+), 578 deletions(-)
The diff is longer than the limit of 39KB.
More information about the pacman-dev
mailing list