[pacman-dev] pacman -Qo takes a very long time

solsTiCe d'Hiver solstice.dhiver at laposte.net
Fri May 11 12:41:13 EDT 2007

so i just installed pacman 3.0.4 during my daily pacman -Syu. no pb libarchive 
and libdownlaod already installed

so the first command i run was:
pacman -Qo /usr/bin/versionpkg and it takes a avery long time !!! wtf ! during 
a compilation . so i stop the comilation and

i time it:
 time pacman -Qo /usr/bin/versionpkg
/usr/bin/versionpkg appartient à versionpkg 0.7.2-1

real    0m19.933s
user    0m17.049s
sys     0m2.316s

and with 100% cpu usage the last 10 second !!??

i run /var/lib/pacman in a tmpfs so the pb of the filesystem fragmentation is 
not a pb. 
so i tried without the tmpfs. 
the same.
i run pacman-optimize.
it takes 51s this time !?

now it's 19s again

-------------- next part --------------
A non-text attachment was scrubbed...
Name: pacman.strace.gz
Type: application/x-gzip
Size: 579290 bytes
Desc: not available
URL: <http://archlinux.org/pipermail/pacman-dev/attachments/20070511/7d15a76f/attachment.bin>

More information about the pacman-dev mailing list