[pacman-dev] alpm_list_last
Sebastian Nowicki
sebnow at gmail.com
Mon Apr 21 01:46:30 EDT 2008
I noticed that alpm_list_last simply returns a pointer to the previous
node. Is this expected behavior? My interpretation of "last" would be
to return the absolute last node, as the comment suggests. In my
opinion the function as it is now should be called alpm_list_prev.
From alpm_list.c:
> alpm_list_t SYMEXPORT *alpm_list_last(const alpm_list_t *list)
> {
> if(list) {
> return(list->prev);
> } else {
> return(NULL);
> }
> }
--
Sebastian Nowicki
More information about the pacman-dev
mailing list