[pacman-dev] [GIT] The official pacman repository branch, master, updated. v3.2.0-50-gd05882d

Nagy Gabor ngaba at bibl.u-szeged.hu
Mon Aug 25 20:36:54 EDT 2008

> This is an automated email from the git hooks/post-receive script. It
> was generated because a ref change was pushed to the repository
> containing the project "The official pacman repository".
> The branch, master has been updated
>        via  d05882db9e417244fa580c4697b45333faffcc79 (commit)
>        via  070135626023caa0186a77f9f846c078e3cf1be8 (commit)
>        via  9dbe5c9d1ee5fb00f25515dfb5a2feb3ae6ebd59 (commit)
>        via  a06d0de104d2f03c19b917ea47394d8d6be89a9a (commit)
>       from  a4100b384737d6b422a31eb0f6614b4f5f6070cb (commit)
> Those revisions listed above that are new to this repository have
> not appeared on any other notification email; so we list those
> revisions in full, below.
> - Log
> -----------------------------------------------------------------
> commit d05882db9e417244fa580c4697b45333faffcc79 Author: Xavier
> Chantry <shiningxc at gmail.com> Date:   Sun Aug 17 19:36:28 2008 +0200
>     Rename alpm_db_get{pkg,grp}cache to alpm_db_get_{pkg,grp}cache
>     This is more consistent with the private functions :
>     _alpm_db_get_{pkg,grp}cache
>     Signed-off-by: Xavier Chantry <shiningxc at gmail.com>
>     Signed-off-by: Dan McGee <dan at archlinux.org>

I am not a big fan of public function renaming, but if this was
accepted, I bring up an other annoying function name convention (imho):
The return values of these functions must be freed unlike other
alpm_*_get_ functions. (The different behaviour can be suspected from
"const char*" vs "char*" only). I may missed some other examples.

IMHO in these cases the use of "compute" instead of "get" would be more
suggestive, see alpm_pkg_compute_requiredby().

> commit 070135626023caa0186a77f9f846c078e3cf1be8
> Author: Xavier Chantry <shiningxc at gmail.com>
> Date:   Sun Aug 17 19:30:36 2008 +0200
>     Change checkdeps and checkdbconflicts to be more flexible.
>     These two functions now take directly a package list rather than
> a database. 
>     checkdbconflicts was renamed to checkconflicts.
>     Signed-off-by: Xavier Chantry <shiningxc at gmail.com>

This is cool.

More information about the pacman-dev mailing list