[pacman-dev] [PATCH] Rename alpm_get_md5sum to alpm_compute_md5sum and alpm_dep_get_string to alpm_dep_compute_string
ngaba at bibl.u-szeged.hu
Tue Aug 26 07:40:16 EDT 2008
> On Tue, Aug 26, 2008 at 1:12 PM, Nagy Gabor <ngaba at bibl.u-szeged.hu>
> > >From aa4384123d2ca6068945f5f9574764dc5f334e67 Mon Sep 17 00:00:00
> > >2001
> > From: Nagy Gabor <ngaba at bibl.u-szeged.hu>
> > Date: Tue, 26 Aug 2008 12:57:08 +0200
> > Subject: [PATCH] Rename alpm_get_md5sum to alpm_compute_md5sum and
> > alpm_dep_get_string to alpm_dep_compute_string
> > This patch introduces the following function name convention:
> > _compute_ in function name: the return value must be freed.
> > _get_ in function name: the return value must not be freed.
> Sounds good to me.
> The only question I have after reading this patch is whether there are
> many others alpm functions which need to have their return value
Well, I gave a look in alpm.h (and alpm_list.h) on function headers
containing "_get". Without further "investigation" (source reading), I
think we had only 2 problematic (public) functions, which were renamed
by the patch.
More information about the pacman-dev