[pacman-dev] alpm_db_get_pkgcache and alpm_db_get_grpcache rename

Sebastian Nowicki sebnow at gmail.com
Sat Dec 27 09:46:13 EST 2008


Recently the alpm_db_get_{pkg,grp}cache() functions were renamed to  
alpm_db_get_{pkg,grp}cache()[1]. Since this is a public API change,  
shouldn't the old functions perhaps simply be deprecated and "alias"  
the new functions, instead of dropping them completely? I'd imagine  
this would potentially break some front-ends if libalpm gets updated,  
as was the case with a project of mine.

[1]: commit: d05882db9e417244fa580c4697b45333faffcc79

More information about the pacman-dev mailing list