[pacman-dev] PATCH: Fix bug 9395 (allow sync to remove unresolvable packages if user wishes)

Xavier shiningxc at gmail.com
Wed Dec 31 10:50:36 EST 2008

On Wed, Dec 31, 2008 at 2:43 PM, Nagy Gabor <ngaba at bibl.u-szeged.hu> wrote:
> Since your _alpm_is_needed code (btw,
> _alpm prefix is not needed here)

Oh indeed, all the static functions should not have any prefix.
Maybe the README file is not perfectly clear about this, but it can be
understood implicitly.

  26 In a general manner, public library functions are named
  27 (examples: alpm_trans_commit(), alpm_release(), alpm_pkg_get_name(), ...).
  28 Internal (and thus private) functions should be named "_alpm_XXX"
for instance
  29 (examples: _alpm_needbackup(), _alpm_runscriplet(), ...).
Functions defined and
  30 used inside a single file should be defined as "static".

More information about the pacman-dev mailing list