[pacman-dev] [PATCH] New --nonew option (resubmit)

Nagy Gabor ngaba at bibl.u-szeged.hu
Wed Mar 5 04:43:34 EST 2008

> So, if I want to use binutils 2.18 with glibc 2.4 then these are the 
> distributions to use...  To clarify, I meant that no distribution will 
> support partially updated systems, in that if the current version of 
> "package 1" does not work with an old version of "package 2" but it does 
> with the latest version, the solution to a bug report won't be update 
> your system.  As I outlined in the original email, I could see many 
> package incompatibilities like this happening if pacman could upgrade 
> part of the system.  That is why I don't like the example command given 
> for the --nonew option.

OK, in the example consider xmms-plugins group. I think 100% acceptable if you
want to upgrade your packages belong to xmms-plugins group (after xmms upgrade)
without upgrading firefox, openoffice etc.
On the other hand, if "package 1" doesn't work with "package 2", then this
should be handled by dependencies (package_1 depends on package_2>=3.0) or
conflicts, since pacman -S "package 1" is also allowed (-S --nonew --needed is
just makes a certain type of package selection easier).


SZTE Egyetemi Könyvtár - http://www.bibl.u-szeged.hu
This mail sent through IMP: http://horde.org/imp/

More information about the pacman-dev mailing list