[pacman-dev] [PATCH] New --nonew option (resubmit)

Roman Kyrylych roman.kyrylych at gmail.com
Wed Mar 5 08:37:57 EST 2008

2008/3/5, Nagy Gabor <ngaba at bibl.u-szeged.hu>:
> > So, if I want to use binutils 2.18 with glibc 2.4 then these are the
>  > distributions to use...  To clarify, I meant that no distribution will
>  > support partially updated systems, in that if the current version of
>  > "package 1" does not work with an old version of "package 2" but it does
>  > with the latest version, the solution to a bug report won't be update
>  > your system.  As I outlined in the original email, I could see many
>  > package incompatibilities like this happening if pacman could upgrade
>  > part of the system.  That is why I don't like the example command given
>  > for the --nonew option.
> OK, in the example consider xmms-plugins group. I think 100% acceptable if you
>  want to upgrade your packages belong to xmms-plugins group (after xmms upgrade)
>  without upgrading firefox, openoffice etc.
>  On the other hand, if "package 1" doesn't work with "package 2", then this
>  should be handled by dependencies (package_1 depends on package_2>=3.0) or
>  conflicts, since pacman -S "package 1" is also allowed (-S --nonew --needed is
>  just makes a certain type of package selection easier).

heh, so many-many gtk2-dependant packages should have
this is just unreal, nobody will want to check that stuff (because
it's not trivial and consumes valuable time)

P.S.: this comment is just about "this should be handled by
dependencies", not about the --nonew.

Roman Kyrylych (Роман Кирилич)

More information about the pacman-dev mailing list