[pacman-dev] [PATCH] Be consistend with naming of handle_deps function

Allan McRae allan at archlinux.org
Fri Aug 7 02:42:13 EDT 2009


All other "dep" functions (check_deps, resolve_deps, remove_deps)
have underscores separating words.

Being consistent, convert handledeps to handle_deps.

Signed-off-by: Allan McRae <allan at archlinux.org>
---
 scripts/makepkg.sh.in |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/scripts/makepkg.sh.in b/scripts/makepkg.sh.in
index b314bb6..94779bc 100644
--- a/scripts/makepkg.sh.in
+++ b/scripts/makepkg.sh.in
@@ -354,7 +354,7 @@ check_deps() {
 	fi
 }
 
-handledeps() {
+handle_deps() {
 	local R_DEPS_SATISFIED=0
 	local R_DEPS_MISSING=1
 
@@ -402,7 +402,7 @@ resolve_deps() {
 		return $R_DEPS_SATISFIED
 	fi
 
-	if handledeps $deplist; then
+	if handle_deps $deplist; then
 		pkgdeps="$pkgdeps $deplist"
 		# check deps again to make sure they were resolved
 		deplist="$(check_deps $*)"
-- 
1.6.4



More information about the pacman-dev mailing list