[pacman-dev] [PATCH] Show 'Required By' in -Si output

Nagy Gabor ngaba at bibl.u-szeged.hu
Thu Oct 8 13:31:55 EDT 2009

> Dan McGee schrieb:
> > Just as we do in -Qi, we can compute required by information for sync
> > database packages. The behavior seems sane; for a given package, the -Si
> > required by will show all packages in *any* sync database that require it.
> > 
> > Implements FS#16244.
> > 
> I was wondering about -Qi too: Finding the contents of the "Required By" 
> field takes some time and I want an option to only show the information 
> that is cheap to get. That same thought would apply to -Si. Maybe abuse 
> -q here (as it has no effect on -Qi or -Si yet) and omit those checks 
> with -Siq or -Qiq.

Combined with my "-Sii would not be coherent with -Qii" complaint above,
maybe we should just move Requiredby to -Qii (and -Sii). And then the
new meaning of -Qii would be: more verbose.


PS: When finally we have fast database, these issues just disappear, so
maybe we should working on that instead of workarounding lots of
things... But that is not easy. ;-)

More information about the pacman-dev mailing list