[pacman-dev] [PATCH] makepkg: refactor absolute filename detection
davekong at archlinux.us
Mon May 24 23:37:05 EDT 2010
Excerpts from Dan McGee's message of 2010-05-24 22:53:28 -0400:
> On Mon, May 17, 2010 at 7:01 AM, Cedric Staniewski <cedric at gmx.ca> wrote:
> > 1) error_source_file_not_found is an ugly name; need to find a better/shorter
> > one. It's not possible to correctly exit makepkg from within a subshell anymore which
> > why these file=... || error_source_file_not_found checks are necessary.
> Yeah this is disgusting. :/
> I am banging my head on this too trying to come up with something
> better and nothing is coming to mind...
How about "missing_source_exit"?
More information about the pacman-dev