[pacman-dev] [GIT] The official pacman repository branch, master, updated. v4.0.1-104-gb264fb9
Dan McGee
dan at archlinux.org
Wed Dec 28 23:33:14 EST 2011
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "The official pacman repository".
The branch, master has been updated
via b264fb9e9ddcc31dc8782390309421965e507383 (commit)
via 1b461374264abd62c54133e544dedd5feb866043 (commit)
via a77e638c773d8a492f8c48e8c15474030a7e3d71 (commit)
via cd75ae46ab10fe295c5a3d3054a3b17eff31122a (commit)
via c34b69b5c7aa86fe76f90577195d13bbcf300658 (commit)
via 38143770a9a1b4b88503fc7b1b9098a5957e0f4e (commit)
via 5b749eeee999b5b332ad7545688297a37542b9a5 (commit)
via aac639351f1eb56c1f8f6f19bfe438400a02c614 (commit)
via a7cb1509317e929043df973a9814145fecc99513 (commit)
via e28f321a486a310aeb3358ceff032793a88e5eb4 (commit)
via bec0b0c8234e9fafbf442c4eb18f92e984ee2516 (commit)
via 6b29374a60e1568ba626b88ca1b1da915ca0a438 (commit)
via 92216c5864efccacf2daa3f4f15de3bb479054bb (commit)
via d95c04945fc85bcc584026f7fded57dc8724ba6a (commit)
from 7b2f68cc21df469342cb1caa7ec8fb27005cd2dd (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
commit b264fb9e9ddcc31dc8782390309421965e507383
Author: Allan McRae <allan at archlinux.org>
Date: Sun Dec 25 19:58:31 2011 +1000
makepkg: calculate exact total file size
The current calculation of the total file size for a package using "du"
suffers from issues in portability and correctness. Especially on btrfs,
this can result in clearly wrong package information such as:
Download Size : 14684.29 KiB
Installed Size : 7628.00 KiB
Use an approach based on "stat" to calculate total file size.
Signed-off-by: Allan McRae <allan at archlinux.org>
Signed-off-by: Dan McGee <dan at archlinux.org>
commit 1b461374264abd62c54133e544dedd5feb866043
Author: Allan McRae <allan at archlinux.org>
Date: Thu Dec 22 16:51:22 2011 +1000
makepkg: Use SKIP in checksum to skip integrity check
Using the value of "SKIP" in the checksum array will cause that
integrity check to be skipped. This makes building packages that
rely on user configurable sources less painful.
Based-on-patch-by: Dan McGee <dan at archlinux.org>
Based-on-patch-by: David Campbell <davekong at archlinux.us>
Signed-off-by: Allan McRae <allan at archlinux.org>
Signed-off-by: Dan McGee <dan at archlinux.org>
commit a77e638c773d8a492f8c48e8c15474030a7e3d71
Author: Lukas Fleischer <archlinux at cryptocrack.de>
Date: Mon Dec 12 22:36:57 2011 +0100
contrib/*: Support the "--help" and "--version" options
Add "--help"/"-h" and "--version"/"-V" support to all contrib scripts.
Also, update scripts that used "-v" as a short option for "--version"
and use "-V" for the sake of consistency.
Additionally:
* Move version and usage messages to separate convenience functions in
all scripts.
* Add a workaround to paccache to support "--help" and "--version". This
should be replaced by a proper POSIX-compliant command line parser
that supports long options in a future patch.
* Add a "$myver" variable to all scripts and use it whenever we refer to
the program version (e.g. in version messages). Also, use the pacman
version number everywhere instead of using a different versioning
scheme for each contrib script. This is achieved by adding a
"PACKAGE_VERSION" placeholder that is replaced by sed(1) when the
script is built.
* Ensure we always return with exit status 0 if "--help" is used and
return with exit status 1 if we display the usage message due to
invalid arguments.
* Add "AUTOMAKE_OPTIONS = std-options" and add all scripts to
"bin_SCRIPTS" to make `make installcheck` check that installed scripts
actually support the "--help" and "--version" options.
Signed-off-by: Lukas Fleischer <archlinux at cryptocrack.de>
Signed-off-by: Dan McGee <dan at archlinux.org>
commit cd75ae46ab10fe295c5a3d3054a3b17eff31122a
Author: Lukas Fleischer <archlinux at cryptocrack.de>
Date: Mon Dec 12 22:36:56 2011 +0100
Makefile.am: Extract "contrib/" into DIST_SUBDIRS
This implies following changes:
* contrib scripts can be built and installed easily by running make(1)
in "contrib/". This removes the need to pick all contrib scripts
manually when packaging pacman-contrib.
* contrib scripts will no longer be built when running make(1) in the
top level source directory. This seems like the most natural approach.
We install those separately and should act the same when building
stuff.
Signed-off-by: Lukas Fleischer <archlinux at cryptocrack.de>
Signed-off-by: Dan McGee <dan at archlinux.org>
commit c34b69b5c7aa86fe76f90577195d13bbcf300658
Author: Dan McGee <dan at archlinux.org>
Date: Fri Dec 23 14:47:30 2011 -0600
Convert strtrim/strlen paired calls to only strtrim
This utilizes the new return value so we don't have to find the length
of the string again.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit 38143770a9a1b4b88503fc7b1b9098a5957e0f4e
Merge: aac6393 5b749ee
Author: Dan McGee <dan at archlinux.org>
Date: Fri Dec 23 14:40:59 2011 -0600
Merge branch 'maint'
commit aac639351f1eb56c1f8f6f19bfe438400a02c614
Author: Dan McGee <dan at archlinux.org>
Date: Fri Dec 23 14:33:26 2011 -0600
Remove strtrim function from backend
The last user of this was the code in the backend for loading packages,
but this no longer uses it.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit a7cb1509317e929043df973a9814145fecc99513
Author: Dan McGee <dan at archlinux.org>
Date: Fri Dec 23 14:32:01 2011 -0600
be_package: be more explicit parsing key/value pairs
This eliminates the need for strtrim() usage completely, instead relying
on the fact that the only allowed delimiter between key and value is the
" = " string.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit e28f321a486a310aeb3358ceff032793a88e5eb4
Author: Dave Reisner <dreisner at archlinux.org>
Date: Fri Dec 23 12:02:49 2011 -0500
pactree: cleanup register_syncs
- take advantage of the new strtrim return value
- tighten scope on line pointer
Signed-off-by: Dave Reisner <dreisner at archlinux.org>
commit bec0b0c8234e9fafbf442c4eb18f92e984ee2516
Author: Dave Reisner <dreisner at archlinux.org>
Date: Fri Dec 23 11:57:19 2011 -0500
pactree: update with new strtrim function
Signed-off-by: Dave Reisner <dreisner at archlinux.org>
commit 6b29374a60e1568ba626b88ca1b1da915ca0a438
Author: Dan McGee <dan at archlinux.org>
Date: Fri Dec 23 10:12:08 2011 -0600
Rework package removal code
Extract the actual unlinking of files into a new method, which
eliminates a goto used for flow control. Also fix up a few small issues
in the code:
* Unnecessary (unsigned long) cast, use '%zd' instead
* Total up errors returned from unlink_file calls and return to caller
* Be consistent with scriptlets- we run pre_remove on dbonly, so we
should also run post_remove. Both can be disabled by way of the
--noscriptlet argument.
* Don't pass an invalid pointer to oldpkg to the event callbacks;
instead call the callback before we free the object.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit 92216c5864efccacf2daa3f4f15de3bb479054bb
Author: Dave Reisner <dreisner at archlinux.org>
Date: Thu Dec 22 08:52:08 2011 -0500
pacman/util: return size_t from strtrim
Instead of returning the same value as the parameter to this function,
return the length of the string, which can be useful to the caller when
its non-zero (e.g. to find the end of the string).
Signed-off-by: Dave Reisner <dreisner at archlinux.org>
-----------------------------------------------------------------------
Summary of changes:
Makefile.am | 4 +-
configure.ac | 1 -
contrib/Makefile.am | 14 ++++++
contrib/bacman.in | 18 +++++----
contrib/paccache.in | 20 ++++++++-
contrib/pacdiff.in | 12 +++++-
contrib/paclist.in | 21 +++++++++-
contrib/paclog-pkglist.in | 19 +++++++-
contrib/pacscripts.in | 10 ++++-
contrib/pacsearch.in | 20 +++++++--
contrib/pacsysclean.in | 13 +++++-
doc/PKGBUILD.5.txt | 7 ++-
lib/libalpm/be_package.c | 21 +++++----
lib/libalpm/remove.c | 99 ++++++++++++++++++++++++--------------------
lib/libalpm/util.c | 41 ------------------
lib/libalpm/util.h | 1 -
scripts/Makefile.am | 1 -
scripts/makepkg.sh.in | 21 +++++----
scripts/pacman-key.sh.in | 6 +-
src/pacman/conf.c | 11 +++--
src/pacman/util.c | 36 +++++++++--------
src/pacman/util.h | 2 +-
src/util/pactree.c | 33 ++++++++-------
23 files changed, 254 insertions(+), 177 deletions(-)
hooks/post-receive
--
The official pacman repository
More information about the pacman-dev
mailing list