[pacman-dev] [PATCH] makepkg: move option parsing code to separte file
snowmaniscool at gmail.com
Wed Jun 8 13:05:28 EDT 2011
On Wed, Jun 8, 2011 at 9:40 AM, Allan McRae <allan at archlinux.org> wrote:
> This move the getopt replacement function parse_options out of
> makepkg.sh.in and into a separate file. The code is inserted
> into the relevant place in makepkg using m4.
> This will allow the reuse of the option parsing code in other
> scripts (i.e. pacman-key) while avoiding code duplication.
> Signed-off-by: Allan McRae <allan at archlinux.org>
> Is there a better way to do this that I am missing?
I noticed that in your new parse_options.sh script you left references
to makepkg in the output messages. Shouldn't a variable be used
More information about the pacman-dev