[pacman-dev] [PATCH] doc/PKGBUILD: misc changes
dpmcgee at gmail.com
Fri Jun 10 13:12:35 EDT 2011
On Fri, Jun 10, 2011 at 4:31 AM, matt mooney <mfm at muteddisk.com> wrote:
> On 09:00 Fri 10 Jun , Florian Pritz wrote:
>> On 10.06.2011 01:58, matt mooney wrote:
>> > Apart from those minor issues, great work! I am a big fan of grammar cleanups ;)
>> Thanks for taking a look at it. I don't want to clutter this ML too much
>> so the fixed patch is available at . Once it's been read by a few
>> more people I'll send the final one for merging.
> Next time you should just resend it inline as [PATCH v2] to allow people to
> comment on the corrected version.
> Acked-by: matt mooney <mfm at muteddisk.com>
Definitely just send it again next time; don't ever worry about
cluttering the ML. Whether a message includes a patch or not, it is
still a message.
Comments (made harder by not inline):
* "The name of the package or an array of names for split packages." -
seems to be looking for an "Either" at the start to pair with the "or"
already there, and then a comma can be put before the or, e.g. "Either
the name of the package, or an array of names for split packages."
Matt, correct me if I'm wrong. :)
* "(re)set" -> "set", I don't think the former adds any clarity.
* source: we seem to have a precedent elsewhere in the docs to put
variables in `` (backticks). Since this got a total rewrite anyway,
feel free to rewrap the whole thing for consistency at the normal
textwidth of 80.
* "It is also possible to overwrite the filename". This seems a bit
misleading- "It is possible to change the name of the downloaded
file..." or something?
* "where makepkg extracts to or copies to all source"- not sure why
this change is being made? Adding the two "to"s doesn't seem like
proper English to me. Also, for these three, we should be consistent
with either "This contains" or "This points to" (I think the former).
* s/of/on/ not sure this is needed?
* (e.g., "makepkg-git", "mplayer-svn"). Elsewhere we already used have
multiple formats, we shouldn't add a third for consistency's sake:
(e.g. '2.7.1'), (e.g. `install=pkgname.install`) .
More information about the pacman-dev