[pacman-dev] [PATCH] Rename mount point struct
allan at archlinux.org
Mon Jun 27 22:46:06 EDT 2011
On 28/06/11 12:26, Dan McGee wrote:
> On Mon, Jun 27, 2011 at 9:26 PM, Allan McRae<allan at archlinux.org> wrote:
>> Rename alpm_mountpoint_t to pmmountpoint_t to keep naming consistent
>> with every other struct we have.
> What if I said "f*** it, it's 4.0, we should fix them all to be alpm_
> like they should have always been"? I'm tempted to actually go the
> other way- this one doesnt matter so much since it is internal to the
> library, but we are very inconsistent with exposing PM_, pmxxx_t, etc.
> when all our functions are rightly named alpm_*().
My thoughts are that I am glad I stopped writing my GTK3 libalpm
frontend when I realised what was happening to the API! :D
I am actually quite comfortable with the distinction that alpm_* is a
function and pm*_t is a type. But saying that, converting the pmxxx_t
to alpm_xxx_t does seem an overall more consistent approach. Our list
type is already prefixed alpm_ and now we have exposed a lot more of
those structs it is probably worth changing them.
And now is the best time to do this. So lets say I am more in favor of
doing this than not (yay for committed answers!). I would be quite
happy to prepare the patchset to do it.
More information about the pacman-dev