[pacman-dev] [PATCH 00/25] Rename types from pmfoo_t to alpm_foo_t

Dan McGee dpmcgee at gmail.com
Tue Jun 28 08:17:17 EDT 2011


On Tue, Jun 28, 2011 at 12:23 AM, Allan McRae <allan at archlinux.org> wrote:
> After discussion here and on IRC, it was decided that rather than
> changing the one struct from alpm_foo_t to pmfoo_t for consistency,
> it would instead be better to rename all the other structs to follow
> the alpm_foo_t scheme.  Given we are pushing towards 4.0, now is the
> best (only?) time to do this.
>
> I am not going to send the enitre patchset here as that would just be
> overkill.  Take a look at the patches in my repo:
> http://projects.archlinux.org/users/allan/pacman.git/log/?h=breakshit

Two observations:
1. Where is pmpkg_t?
2. Does anyone else find "grp" kind of silly? pkg is ubiquitous and at
least less than 50% of the length of package, but I might propose
shifting the type name to "alpm_group_t".

> Allan McRae (25):
>  Rename pmpkgreason_t to alpm_pkgreason_t
>  Rename pmdepmod_t to alpm_depmod_t
>  Rename pmfileconflicttype_t to alpm_fileconflicttype_t
>  Rename pmhandle_t to alpm_handle_t
>  Rename pmdb_t to alpm_db_t
>  Rename pmtrans_t to alpm_trans_t
>  Rename pmdepend_t to alpm_depend_t
>  Rename pmdepmissing_t to alpm_depmissing_t
>  Rename pmconflict_t to alpm_conflict_t
>  Rename pmfileconflict_t to alpm_fileconflict_t
>  Rename pmgrp_t to alpm_grp_t
>  Rename pmdelta_t to alpm_delta_t
>  Rename pmbackup_t to alpm_backup_t
>  Rename pmloglevel_t to alpm_loglevel_t
>  Rename pmtransflag_t to alpm_transflag_t
>  Rename pmtransevt_t to alpm_transevt_t
>  Rename pmtransconv_t to alpm_transconv_t
>  Rename pmtransprog_t to alpm_transprog_t
>  Rename pmerrno_t to alpm_errno_t
>  Rename pmpkgfrom_t to alpm_pkgfrom_t
>  Rename pmgraph_t to alpm_graph_t
>  Rename pmpkghash_t to alpm_pkghash_t
>  Rename pmtransstate_t to alpm_transstate_t
>  Rename pmdbinfrq_t to alpm_dbinfrq_t
>  Rename _pmdbstatus_t to _alpm_dbstatus_t
>
>  lib/libalpm/add.c        |   34 +++---
>  lib/libalpm/add.h        |    2 +-
>  lib/libalpm/alpm.c       |   12 +-
>  lib/libalpm/alpm.h       |  354 +++++++++++++++++++++++-----------------------
>  lib/libalpm/backup.c     |   16 +-
>  lib/libalpm/backup.h     |    8 +-
>  lib/libalpm/be_local.c   |   82 ++++++------
>  lib/libalpm/be_package.c |   30 ++--
>  lib/libalpm/be_sync.c    |   34 +++---
>  lib/libalpm/conflict.c   |   62 ++++----
>  lib/libalpm/conflict.h   |   12 +-
>  lib/libalpm/db.c         |   92 ++++++------
>  lib/libalpm/db.h         |   62 ++++----
>  lib/libalpm/delta.c      |   68 +++++-----
>  lib/libalpm/delta.h      |    8 +-
>  lib/libalpm/deps.c       |  136 +++++++++---------
>  lib/libalpm/deps.h       |   16 +-
>  lib/libalpm/diskspace.c  |   18 ++--
>  lib/libalpm/diskspace.h  |    2 +-
>  lib/libalpm/dload.c      |    6 +-
>  lib/libalpm/dload.h      |    4 +-
>  lib/libalpm/error.c      |    4 +-
>  lib/libalpm/graph.c      |    8 +-
>  lib/libalpm/graph.h      |    8 +-
>  lib/libalpm/group.c      |    8 +-
>  lib/libalpm/group.h      |    4 +-
>  lib/libalpm/handle.c     |  108 +++++++-------
>  lib/libalpm/handle.h     |   20 ++--
>  lib/libalpm/log.c        |    4 +-
>  lib/libalpm/log.h        |    2 +-
>  lib/libalpm/package.c    |  154 ++++++++++----------
>  lib/libalpm/package.h    |   86 ++++++------
>  lib/libalpm/pkghash.c    |   36 +++---
>  lib/libalpm/pkghash.h    |   18 ++--
>  lib/libalpm/remove.c     |   48 +++---
>  lib/libalpm/remove.h     |    8 +-
>  lib/libalpm/signing.c    |   12 +-
>  lib/libalpm/signing.h    |    4 +-
>  lib/libalpm/sync.c       |  108 +++++++-------
>  lib/libalpm/sync.h       |    4 +-
>  lib/libalpm/trans.c      |   38 +++---
>  lib/libalpm/trans.h      |   20 ++--
>  lib/libalpm/util.c       |   14 +-
>  lib/libalpm/util.h       |   18 ++--
>  src/pacman/callback.c    |   10 +-
>  src/pacman/callback.h    |    8 +-
>  src/pacman/conf.c        |    8 +-
>  src/pacman/conf.h        |    4 +-
>  src/pacman/database.c    |    4 +-
>  src/pacman/deptest.c     |    2 +-
>  src/pacman/package.c     |   14 +-
>  src/pacman/package.h     |    8 +-
>  src/pacman/query.c       |   36 +++---
>  src/pacman/remove.c      |   14 +-
>  src/pacman/sync.c        |   80 +++++-----
>  src/pacman/upgrade.c     |   12 +-
>  src/pacman/util.c        |   40 +++---
>  src/pacman/util.h        |   14 +-
>  src/util/cleanupdelta.c  |   10 +-
>  src/util/pactree.c       |   18 ++--
>  src/util/testdb.c        |   14 +-
>  src/util/testpkg.c       |    8 +-
>  62 files changed, 1048 insertions(+), 1048 deletions(-)
>
> --
> 1.7.6
>
>
>


More information about the pacman-dev mailing list