[pacman-dev] [PATCH 00/25] Rename types from pmfoo_t to alpm_foo_t
allan at archlinux.org
Tue Jun 28 09:19:24 EDT 2011
On 28/06/11 22:32, Allan McRae wrote:
> On 28/06/11 22:17, Dan McGee wrote:
>> On Tue, Jun 28, 2011 at 12:23 AM, Allan McRae<allan at archlinux.org> wrote:
>>> After discussion here and on IRC, it was decided that rather than
>>> changing the one struct from alpm_foo_t to pmfoo_t for consistency,
>>> it would instead be better to rename all the other structs to follow
>>> the alpm_foo_t scheme. Given we are pushing towards 4.0, now is the
>>> best (only?) time to do this.
>>> I am not going to send the enitre patchset here as that would just be
>>> overkill. Take a look at the patches in my repo:
>> Two observations:
>> 1. Where is pmpkg_t?
> In with pmtrans_t for some reason... will fix!
>> 2. Does anyone else find "grp" kind of silly? pkg is ubiquitous and at
>> least less than 50% of the length of package, but I might propose
>> shifting the type name to "alpm_group_t".
> Seems reasonable to me. I can adjust this.
Do we want function names with "grp" in them to be changed too? e.g.
alpm_option_add_ignoregrp, alpm_db_readgrp, alpm_db_get_grpcache, etc...
That can come in a separate patchset.
More information about the pacman-dev