[pacman-dev] [GIT] The official pacman repository branch, master, updated. v4.0.0rc1-218-g8375ad2
Dan McGee
dan at archlinux.org
Tue Sep 20 11:34:55 EDT 2011
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "The official pacman repository".
The branch, master has been updated
via 8375ad214a2a8d6e01430f432aa7957688d8ec52 (commit)
via b7ebacc576ea63fd35861f374dd345f6aa8feb8c (commit)
via ec790ced7cee00269234cb1ed476e29256433923 (commit)
via 994cb4da4f6bc8efbb6a649cb7d99d95bce5c37a (commit)
via a27f993600a518ef6a15bd7fb29575b218b58a0a (commit)
via afdbfc05f771f2c684ee195b46d26b3d08a67085 (commit)
via 7eb2f0cd151998d36746e2eb14cad2a3f8fb708b (commit)
via 8e3b39a9e0c2fbc268919a57fb1e3cf7aa2aedf4 (commit)
via 0f92fc59638e5d053966c8f39afd615a870141cc (commit)
via 79cbce60ac4a40bf11d039e9bdcd09c852ce3292 (commit)
via 70e2c34f0f5db329b8e92fe3fc3043e495272f14 (commit)
via 37961648486ca44a92eefe454cd6f1f091c4fe6d (commit)
via 95119d46d486168e7fddd5e8eece93be8e9ca719 (commit)
via 288a81d8470b1fd2e8a8f0814abe4cbfed71497c (commit)
via bfe36c2ddf869e2ebc44bec1e35c0319263ac386 (commit)
via e1899cbc64c6b634107f09c3a3e8152c63078636 (commit)
via a94ad2974031138dbb4d42a939dfc0cd15a75ce7 (commit)
from 41d8deff88ed7bdaf1820882687fb99107f60d2a (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
commit 8375ad214a2a8d6e01430f432aa7957688d8ec52
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 23:47:06 2011 -0500
_alpm_sync_commit: extract two static methods
This adds two new static methods, check_validity() and load_packages(),
to sync.c which are simply code fragments pulled out of our
do-everything sync commit code.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit b7ebacc576ea63fd35861f374dd345f6aa8feb8c
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 23:28:05 2011 -0500
Pass package signature data up one more level
Signed-off-by: Dan McGee <dan at archlinux.org>
commit ec790ced7cee00269234cb1ed476e29256433923
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 22:53:15 2011 -0500
signing: add a process and retry loop for database signatures
In reality, there is no retrying that happens as of now because we don't
have any import or changing of the keyring going on, but the code is set
up so we can drop this in our new _alpm_process_siglist() function. Wire
up the basics to the sync database validation code, so we see something
like the following:
$ pacman -Ss unknowntrust
error: core: signature from "Dan McGee <dpmcgee at gmail.com>" is unknown trust
error: core: signature from "Dan McGee <dpmcgee at gmail.com>" is unknown trust
error: database 'core' is not valid (invalid or corrupted database (PGP signature))
$ pacman -Ss missingsig
error: core: missing required signature
error: core: missing required signature
error: database 'core' is not valid (invalid or corrupted database (PGP signature))
Yes, there is some double output, but this should be fixable in the
future.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit 994cb4da4f6bc8efbb6a649cb7d99d95bce5c37a
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 21:51:30 2011 -0500
Allow our PGP helper method to pass back the signature results
This will make its way up the call chain eventually to allow trusting
and importing of keys as necessary.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit a27f993600a518ef6a15bd7fb29575b218b58a0a
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 21:01:26 2011 -0500
Split package validation and load loops
This adds a some new callback event and progress codes for package
loading, which was formerly bundled in with package validation before.
The main sync.c loop where loading occurred is now two loops running
sequentially. The behavior should not change with this patch outside of
progress and event display; more changes will come in following patches.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit afdbfc05f771f2c684ee195b46d26b3d08a67085
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 20:40:32 2011 -0500
Extract an _alpm_pkg_validate_internal() method
_alpm_pkg_load_internal() was becoming a monster. Extract the top bit of
the method that dealt with checksum and signature validation into a
separate method that should be called before one loads a package to
ensure it is valid.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit 7eb2f0cd151998d36746e2eb14cad2a3f8fb708b
Author: Dave Reisner <dreisner at archlinux.org>
Date: Mon Sep 19 22:09:15 2011 -0400
pacman/upgrade: print 'loading packages...' only once
Do this outside the loop to prevent the message from being displayed
(and pluralized!) for each individual package.
Signed-off-by: Dave Reisner <dreisner at archlinux.org>
Signed-off-by: Dan McGee <dan at archlinux.org>
commit 8e3b39a9e0c2fbc268919a57fb1e3cf7aa2aedf4
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 19:57:29 2011 -0500
pacman: use dynamic string allocation where it makes sense
None of these are hot-code paths, and at least the target reading has
little need for an arbitrary length limitation (however crazy it might
be to have longer arguments).
Signed-off-by: Dan McGee <dan at archlinux.org>
commit 0f92fc59638e5d053966c8f39afd615a870141cc
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 19:15:16 2011 -0500
utils/cleanupdelta: remove unneeded syncdbpath
This variable was totally unused.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit 79cbce60ac4a40bf11d039e9bdcd09c852ce3292
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 14:32:53 2011 -0500
Remove all usages of alpm_list_getdata() from the library
No need for the indirection; just access ->data instead.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit 70e2c34f0f5db329b8e92fe3fc3043e495272f14
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 14:28:18 2011 -0500
_alpm_runscriptlet(): remove clean_tmpdir variable
This is always true at the end since we return early if we couldn't
create the tmpdir, so it is totally unnecessary.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit 37961648486ca44a92eefe454cd6f1f091c4fe6d
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 14:27:21 2011 -0500
Access db->pkgcache directly in db_free_pkgcache()
We shouldn't be going through the accessor that does a bunch of
unnecessary legwork, including potentially loading the pkgcache right
before we free it.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit 95119d46d486168e7fddd5e8eece93be8e9ca719
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 19:55:16 2011 -0500
Flip getcwd()/chdir() for open()/fchdir() in the frontend
Just like we did in libalpm in commit 288a81d8470b1.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit 288a81d8470b1fd2e8a8f0814abe4cbfed71497c
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 14:08:14 2011 -0500
Use more efficient way of restoring working directory
Rather than using a string-based path, we can restore the working
directory via a file descriptor and use of fchdir().
From the getcwd manpage:
Opening the current directory (".") and calling fchdir(2) to
return is usually a faster and more reliable alternative when
sufficiently many file descriptors are available.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit bfe36c2ddf869e2ebc44bec1e35c0319263ac386
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 13:43:13 2011 -0500
Reduce path allocation on the stack in local database
We did a lot of both malloc-ing and stack printing to form some paths in
this code. Attempt to unify it all into the one get_pkgpath() method by
adding an optional third "filename" parameter, and form the necessary
path string all in one go.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit e1899cbc64c6b634107f09c3a3e8152c63078636
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 13:18:42 2011 -0500
Be smarter about running ldconfig during removal transactions
1. Don't run it if something failed in package removal- this mirrors
what we already do in sync transactions.
2. Don't run it if we are invoking it for the replaces removal bit of a
sync transaction- it doesn't make sense to run ldconfig halfway through
a sync install; we should only run it once at the end.
Signed-off-by: Dan McGee <dan at archlinux.org>
commit a94ad2974031138dbb4d42a939dfc0cd15a75ce7
Author: Dan McGee <dan at archlinux.org>
Date: Mon Sep 19 13:17:16 2011 -0500
Search for non-prefixed paths in skip_remove list
We add them to this list with the root path not appended; we should be
searching for them this way as well.
Signed-off-by: Dan McGee <dan at archlinux.org>
-----------------------------------------------------------------------
Summary of changes:
lib/libalpm/add.c | 19 ++++--
lib/libalpm/alpm.h | 5 ++
lib/libalpm/be_local.c | 67 ++++++++++---------
lib/libalpm/be_package.c | 93 +++++++++++++++++----------
lib/libalpm/be_sync.c | 18 +++++-
lib/libalpm/db.c | 6 +-
lib/libalpm/deps.c | 3 +-
lib/libalpm/handle.c | 2 +-
lib/libalpm/package.c | 2 +-
lib/libalpm/package.h | 8 ++-
lib/libalpm/remove.c | 20 +++---
lib/libalpm/remove.h | 2 +-
lib/libalpm/signing.c | 87 +++++++++++++++++++++++---
lib/libalpm/signing.h | 6 ++-
lib/libalpm/sync.c | 158 +++++++++++++++++++++++++++++++---------------
lib/libalpm/trans.c | 13 ++---
lib/libalpm/util.c | 44 ++++++++-----
src/pacman/callback.c | 9 +++
src/pacman/conf.c | 24 ++++---
src/pacman/pacman.c | 25 ++++++--
src/pacman/sync.c | 8 ++-
src/pacman/upgrade.c | 2 +-
src/pacman/util.c | 10 +++-
src/util/cleanupdelta.c | 15 ++---
24 files changed, 437 insertions(+), 209 deletions(-)
hooks/post-receive
--
The official pacman repository
More information about the pacman-dev
mailing list