[pacman-dev] [GIT] The official pacman repository annotated tag, v4.0.0rc2, created. v4.0.0rc2
Dan McGee
dan at archlinux.org
Thu Sep 22 12:53:44 EDT 2011
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "The official pacman repository".
The annotated tag, v4.0.0rc2 has been created
at 58b4f02d2e0f46c6694f701998e549c6cf17f5ed (tag)
tagging 43787d00678e00adee54c9ab4b8909d26cba3940 (commit)
replaces v4.0.0rc1
tagged by Dan McGee
on Thu Sep 22 11:51:26 2011 -0500
- Log -----------------------------------------------------------------
4.0.0 RC2- import keys, fully test signing
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
iEYEABECAAYFAk57Z58ACgkQXC5GoPU6du2y0wCgooXA6y4dtDn0uQN3FGsed2np
xLoAoLq8Mr5CViBLqnIj4RQBDKHMM1UU
=fKRN
-----END PGP SIGNATURE-----
Allan McRae (12):
repo-add: indicate whether package signature is found
repo-add: fix creation of signature symlink
configure.ac: add checks for more types, functions and headers
makepkg: deal with variable substitution when checking sanity
Print callback messages to stderr
pacman-key: rework importing distro/repo provided keyrings
pacman-key: import everything then revoke on --populate
pacman-key: update trust database for relevant operations
pacman-key: Improve documentation for --populate
pacman-key: rework and document holding keys in keyring
Run pacman test-suite with LC_ALL=C
Remove outdated comment for _alpm_outerconflicts
Dan McGee (148):
scripts/pkgdelta: fix `make distcheck`
pacman/query.c: avoid variable redeclaration
Update MD5 routines with changes from PolarSSL
Update base64 PolarSSL code
Add sha2 (sha256) routines from PolarSSL
Add ALPM sha256sum routines
Load and allow access to sha256sum
Remove checksum access indirection
decode_signature: guess signature data length for efficiency
Show 'None' in Signatures -Qip/-Si output if none found
Validate the sha256sum if available
Parse conflicts/provides/replaces at database load time
Add short example signature config to pacman.conf
Further fixes to replacement iteration
Only check necessary signatures and checksums
repo-add: reorganize output messages for clarity
Update translations from Transifex
Update message catalogs
Update authors and contributors
doc/PKGBUILD: fix Asciidoc formatting issues
Fix compilation using --without-gpgme
Fix trailing whitespace in whole codebase
Enhance and utilize database status flags
Remove use of no-op accessor functions in library
Remove usages of alpm_list_next() in backend
Replacements refactor: extract check_literal()
Replacements refactor: extract check_replacers()
Add an _alpm_depcmp_literal() function
Fix replacement of provider issue
Convert resolvedep() to use _alpm_depcmp_literal()
doc/PKGBUILD: update regarding versioned package fields
Be more robust when copying package data
Rework finding a writable cache directory
Remove alpm_option_get_* usage from backend
pacsort: ensure list is freed if size is 0
Print debug timestamps to same stream as rest of output
dload: prevent need to copy struct in mask_signal()
Retrieve default SigLevel value from backend after initial setting
Style-match rpmvercmp code with upstream
vercmp: ensure 2.0a and 2.0.a do not compare equal
Update existing translations from Transifex
Add new 'lt' and 'zh_TW' translations from transifex
Use off_t rather than double where possible
Finish large file download attack prevention
Add a few more sizes to humanize_sizes()
Slight refresh of the download progress callback
Remove short/long label distinction
Remove trans is NULL check in QUESTION/EVENT/PROGRESS macros
Remove argument from check_pgp_helper
strtrim: don't move empty string
Fix small memory leak in sig check code
Always process validity value returned by gpgme
Fix possible mismatched type with several curl arguments
Make sync error message smarter on unfound targets
Check local database status flag in db_write sanity check block
Refactor signature result return format
Add more info to debug key display
Refactor some args out of pkg_load_internal
Better error handling out of package load method
pacman-key: refine permission and locking checks
pacman-key: have --init add more options to default gpg.conf
Allow access to package origin data
Database read optimizations
_alpm_splitdep(): don't pass bogus length value to strndup
Merge branch 'allan/pacman-key'
Rework scriptlet tests to not depend on pacman output
Streamline alpm_splitdep() comparisons
pacman-key: fix broken logic around updating trust database
Ensure progress callback updates if XX/YY numerator changes
Parse > 2GiB file sizes correctly
Scale package integrity progress bar/percentage by package size
pacman-key master key generation
pacman-key: add --lsign-key operation
makepkg: fix overzealous PGP signature file matching
Add pactest for overflowing date (year 2038 problem)
_alpm_parsedate(): return time_t and not long
pactest: remove PACMAN_OUTPUT from ldconfig tests
Clean up handling of size fields
pacman-key: document --lsign-key
doc: consistency when referencing other options
pacman-key help and documentation cleanup
pacman-key: split keyserver to a separate option
pacman-key: add --refresh-keys operation
Make delta validation/application more logical
Be fully silent on any -Sp operation
Move all callbacks up to the handle level
Former transaction callback rename refactor
Add -p/--print tip for -Q operations on filepath
More package operations cleanup
dload: use intmax_t when printing off_t
Ensure PackageRequired works as expected
Remove unnecessary cast
query check: use provided filelist count instead of keeping track
Use more correct integer types in diskspace checks
Print 'loading packages' message on -U operations
Move download callback static vars into function
download callback: show decimal places in rate if we have room
Don't duplicate header strings
Fix build without gpgme
Ensure entire struct is zeroed in _alpm_parsedate()
Add a random pactest
Remove dead changelog_feof() code
Remove const specifier from changelog_read() void parameter
be_local: cope with a desc file without trailing newline
Search for non-prefixed paths in skip_remove list
Be smarter about running ldconfig during removal transactions
Reduce path allocation on the stack in local database
Use more efficient way of restoring working directory
Flip getcwd()/chdir() for open()/fchdir() in the frontend
Access db->pkgcache directly in db_free_pkgcache()
_alpm_runscriptlet(): remove clean_tmpdir variable
Remove all usages of alpm_list_getdata() from the library
utils/cleanupdelta: remove unneeded syncdbpath
pacman: use dynamic string allocation where it makes sense
Extract an _alpm_pkg_validate_internal() method
Split package validation and load loops
Allow our PGP helper method to pass back the signature results
signing: add a process and retry loop for database signatures
Pass package signature data up one more level
_alpm_sync_commit: extract two static methods
Fix int/size_t type in alpm_list_count() call
Remove noisy debug logger
Fix possible segfault if siglist was empty
validate_deltas: split verify/check errors loops
Move default siglevel value from backend to frontend
Add alpm_capabilities() method and enumeration
Check capabilities in SigLevel option parsing
Pull option names out of messages in config parsing
config parsing: include file and line number in more errors
config parsing: add note if libcurl disabled and no XferCommand
Fix signature printing in package info
Add new import key question enum value and stub frontend function
Add _alpm_process_siglist() logic to failed package validation
signing: document most undocumented functions
Implement PGP key search and import
pacman-key: ensure array iterations are quoted
pacman-key: clean up populate output
pacman-key: print message in populate if signature is missing
pacman-key: don't hide --verify details in populate
pacman-key: simplify import in populate
Add status and check for key being disabled
pacman-key: disable, don't remove, revoked keys
pacman-key: implement promptless lsigning
pacman-key: remove holdkeys functionality
pacman-key: factor out validate_with_gpg() method
pacman-key: add an additional plain text 'foo-trusted' file
Translation file updates from Transifex
Regenerate message catalogs and translations
Dave Reisner (67):
lib/dload: avoid deleting .part file on too-slow xfer
pactest/sync200: check for curl instead of fetch
add pactest for replacing a shared provider
alpm.h: fix inconsistency in function prototype
makepkg: don't hardcode path to strip
README: update with 3.5.0 -> 4.0.0 API changes
pacman/package: show presence of signature in in -Si
lib/sync: reset flag after rejecting a replace
dist: preserve symlinks on installation
build-sys: always use $(RM) instead of rm -f
lib/sync: ignore download errors for as long as possible
dload: zero out pm_errno in curl_download_internal
lib/dload: avoid renaming download to 0 length destfile
lib/dload: refactor deletion on failure
sync: fix garbled output in conflict prompt
lib/dload: prevent possible NULL dereference
makepkg: quote re-evaluation of simple vars
dload: add 'unlink_on_fail' to payload struct
lib/dload: unlink on response code >=400
bash_completion: add dbonly to sync options
dload: remove code duplication
dload: rename payload->filename to payload->remote_name
dload: delete zero length downloads on curl error
dload: remove unused macro
pacman/util: use string_length to calculate line length
dload: move tempfile and destfile to payload struct
dload: rename cd_filename to content_disp_name
dload: add open_mode to payload struct
dload: move curl option setting to static function
dload: move (un)masking of signals to separate functions
dload: extract tempfile creation to its own function
sync: halt file discovery if repo has no servers
pacsort: use boolean, not binary OR operation
makepkg: fix breakage in eval'ing quoted strings
makepkg: read filenames in a while loop
makepkg: fix sanity checking in versioning
pacman/callback: reuse strlen calculation
avoid blowing out the filecache list when using tmpdir
sync: add missing newline in warning message
dload: improve debug output
dload: abstract dload_interrupted reasons
rankmirrors: properly sort resulting times
makepkg: unset variables as per !{make,build}flags
makepkg: use globs in place of regex
makepkg: refactor check_pgpsigs output
makepkg: act on function return value, not output
makepkg: avoid for loop in deleting manpage hardlinks
makepkg: use more awk'ish syntax in sanity checks
diskspace: fix memory leak on root mount not found
paccache: escape . in trimming of diskspace string
makepkg: unset errexit when sourcing /etc/profile
dload: provide optional netrc support
make compute_download_size consider .part files
account for partial delta files in download size
makepkg: check for var existance before file existance
makepkg: add missing newline on passing gpg sourcecheck
makepkg: fix recreation of hardlinks to .gz manpages
buildsys: remove existing symlinks before installing
include ldconfig.stub in EXTRA_DIST
pacman: add short opt '-p' for --print to -{S,R}h
paccache: remove unnecessary if check
dload: remove user:pass@ definition from hostname
configure: Fix quoting in SEDINPLACE on Darwin
pactree: include missing ctype.h header
dload: avoid using memrchr
src/util: provide strndup definitions where needed
pacman/upgrade: print 'loading packages...' only once
Diogo Sousa (3):
Improved alpm_list_mmerge() performance (fixed coding style)
lib/libalpm/signing.c: Fix memory leak in decode_signature() in case of error.
Removed multiple definitions of pkgfrom_t
Helder Martins (1):
lib/libalpm/handle.c: Removed redundant if condition
Jakob Gruber (1):
Fix formatting in pacman-key manpage
Lukas Fleischer (7):
Skip rename() on NULL destfile in curl_download_internal()
Avoid stat() on NULL path in curl_download_internal()
lib/libalpm/dload.c: Add ASSERT() to alpm_fetch_pkgurl()
lib/libalpm/dload.c: Use STRDUP() instead of strdup()
pacman.c: Remove redundant strdup() in parsearg_global()
be_sync.c: Fix memory leak in alpm_db_update()
lib/libalpm/util.c: Fix two memory leaks
Pang Yan Han (4):
pactest: -U --recursive
pacsort: correct pointer type in list_new
pacsort: correct list freeing
Improve advice for sync ops when db.lck is present
Rémy Oudompheng (1):
libalpm: fix a remaining old syntax of RET_ERR() macro
Sebastien Luttringer (2):
Update PKGBUILD manpage about startdir deprecation
Add makepkg -S which is an alias to makepkg --source
-----------------------------------------------------------------------
hooks/post-receive
--
The official pacman repository
More information about the pacman-dev
mailing list