[pacman-dev] [GIT] The official pacman repository branch, master, updated. v4.0.3-305-g0c62b36

Dan McGee dan at archlinux.org
Tue Jun 26 00:47:05 EDT 2012


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "The official pacman repository".

The branch, master has been updated
       via  0c62b36c19d67939d7a84159c86a5de73fd9d36f (commit)
       via  47711947ddf95032334fbe9dd912cbd8d146e174 (commit)
       via  b1bb2eaa50e436e2221a1aec9749de58e4234b44 (commit)
       via  a98fce08968febe7395b30f15f070f400da089ed (commit)
       via  ab8431c92953c4562af214e5170f8ef321037108 (commit)
       via  b58489d29a1898a4bff1b5da6ca4bfb14003dbfe (commit)
       via  e183522e3168c4a31103b3c7910fa8d29333fb5a (commit)
       via  82c999a8bfbffab4740742b4746435f5f1657643 (commit)
      from  377cc23a09f7605e1f14ab89933f4d7dc69bc2cf (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 0c62b36c19d67939d7a84159c86a5de73fd9d36f
Author: Allan McRae <allan at archlinux.org>
Date:   Sat May 19 23:36:30 2012 +1000

    Allow leading "local/" in query operations
    
    I find that when copying the output of "pacman -Qs foo" into a
    "pacman -Qi" operation to get more information on the packages, I
    consistently copy the "local/" prefix. It is a minor usability
    improvement to strip this if present.
    
    Dan: Pluck out LOCAL_PREFIX and magic numbers.
    
    Signed-off-by: Allan McRae <allan at archlinux.org>

commit 47711947ddf95032334fbe9dd912cbd8d146e174
Author: Allan McRae <allan at archlinux.org>
Date:   Tue May 8 23:32:43 2012 +1000

    Scripts testsuite output consistency
    
    Signed-off-by: Allan McRae <allan at archlinux.org>

commit b1bb2eaa50e436e2221a1aec9749de58e4234b44
Author: Dave Reisner <dreisner at archlinux.org>
Date:   Sun May 6 19:47:47 2012 -0400

    paccache: adopt size_to_human
    
    Signed-off-by: Dave Reisner <dreisner at archlinux.org>

commit a98fce08968febe7395b30f15f070f400da089ed
Author: Dave Reisner <dreisner at archlinux.org>
Date:   Sun May 6 18:27:43 2012 -0400

    scripts/library: add size_to_human
    
    This function is the reverse of human_to_size, and converts integer byte
    sizes to human readable SI prefixed values.
    
    A logical extension of this might be to mimic the formatter that pacman
    uses and allow a second argument to be passed in which can coerce the
    size, rather than reducing until the unit count is below 1024.
    
    Signed-off-by: Dave Reisner <dreisner at archlinux.org>

commit ab8431c92953c4562af214e5170f8ef321037108
Author: Dave Reisner <dreisner at archlinux.org>
Date:   Wed Apr 25 22:28:39 2012 -0400

    pkgdelta: use human_to_size to parse --min-pkg-size
    
    Update the documentation accordingly to mention that users can expect
    huamn readable sizes to be acceptable.
    
    Signed-off-by: Dave Reisner <dreisner at archlinux.org>

commit b58489d29a1898a4bff1b5da6ca4bfb14003dbfe
Author: Dave Reisner <dreisner at archlinux.org>
Date:   Wed Apr 25 22:27:19 2012 -0400

    scripts/library: add human_to_size
    
    This is a bash wrapper around an awk function that parses human readable
    sizes and returns their representative values in bytes, as a string. A
    small test harness is added to validate the functionality.
    
    Signed-off-by: Dave Reisner <dreisner at archlinux.org>

commit e183522e3168c4a31103b3c7910fa8d29333fb5a
Author: Dave Reisner <dreisner at archlinux.org>
Date:   Sun Apr 29 15:00:38 2012 -0400

    diskspace: only load filesystem info on demand
    
    Only load filesystem details for the mount points that we're actually
    going to write to. This reduces our syscall count considerably. In the
    case of installation, we would actually stat every mountpoint twice (an
    extra round for download diskspace) which means (on my system) a total
    of 60 syscalls to write to 3 partitions when installing the kernel
    package. This change reduces the 60 syscalls down to the expected 3.
    
    A slight debug output change is added here to discern between a
    mountpoint added to our linked list versus when we actually load the fs
    info.
    
    Signed-off-by: Dave Reisner <dreisner at archlinux.org>
    Signed-off-by: Dan McGee <dan at archlinux.org>

commit 82c999a8bfbffab4740742b4746435f5f1657643
Author: Dave Reisner <dreisner at archlinux.org>
Date:   Sun Apr 29 14:54:10 2012 -0400

    diskspace: dedupe code for loading FS usage
    
    add mount_point_load_fsinfo() for platforms using getmntent().
    
    Dan: move the #ifdef slightly so we don't have unused functions on
    certain platforms (e.g., OS X).
    
    Signed-off-by: Dave Reisner <dreisner at archlinux.org>
    Signed-off-by: Dan McGee <dan at archlinux.org>

-----------------------------------------------------------------------

Summary of changes:
 Makefile.am                        |    2 +
 contrib/Makefile.am                |    2 +-
 contrib/paccache.sh.in             |   21 +---------
 doc/pkgdelta.8.txt                 |    3 +-
 lib/libalpm/diskspace.c            |   81 ++++++++++++++++++++++++------------
 lib/libalpm/diskspace.h            |    7 ++++
 scripts/Makefile.am                |    4 +-
 scripts/library/README             |   12 ++++++
 scripts/library/human_to_size.sh   |   51 +++++++++++++++++++++++
 scripts/library/size_to_human.sh   |   22 ++++++++++
 scripts/pkgdelta.sh.in             |   13 +++---
 src/pacman/query.c                 |    9 +++-
 test/scripts/Makefile.am           |    3 +-
 test/scripts/human_to_size_test.sh |   75 +++++++++++++++++++++++++++++++++
 test/scripts/parseopts_test.sh     |    4 +-
 15 files changed, 250 insertions(+), 59 deletions(-)
 create mode 100644 scripts/library/human_to_size.sh
 create mode 100644 scripts/library/size_to_human.sh
 create mode 100644 test/scripts/human_to_size_test.sh


hooks/post-receive
-- 
The official pacman repository


More information about the pacman-dev mailing list