[arch-commits] Commit in nvidia-304xx/repos (10 files)

Tobias Powalowski tpowa at archlinux.org
Wed Nov 26 13:39:45 UTC 2014


    Date: Wednesday, November 26, 2014 @ 14:39:45
  Author: tpowa
Revision: 227128

db-move: moved nvidia-304xx from [testing] to [extra] (i686, x86_64)

Added:
  nvidia-304xx/repos/extra-i686/PKGBUILD
    (from rev 227126, nvidia-304xx/repos/testing-i686/PKGBUILD)
  nvidia-304xx/repos/extra-i686/nvidia.install
    (from rev 227126, nvidia-304xx/repos/testing-i686/nvidia.install)
  nvidia-304xx/repos/extra-x86_64/PKGBUILD
    (from rev 227126, nvidia-304xx/repos/testing-x86_64/PKGBUILD)
  nvidia-304xx/repos/extra-x86_64/nvidia.install
    (from rev 227126, nvidia-304xx/repos/testing-x86_64/nvidia.install)
Deleted:
  nvidia-304xx/repos/extra-i686/PKGBUILD
  nvidia-304xx/repos/extra-i686/nvidia.install
  nvidia-304xx/repos/extra-x86_64/PKGBUILD
  nvidia-304xx/repos/extra-x86_64/nvidia.install
  nvidia-304xx/repos/testing-i686/
  nvidia-304xx/repos/testing-x86_64/

-----------------------------+
 /PKGBUILD                   |  106 ++++++++++++++++++++++++++++++++++++++++++
 /nvidia.install             |   30 +++++++++++
 extra-i686/PKGBUILD         |   53 ---------------------
 extra-i686/nvidia.install   |   15 -----
 extra-x86_64/PKGBUILD       |   53 ---------------------
 extra-x86_64/nvidia.install |   15 -----
 6 files changed, 136 insertions(+), 136 deletions(-)

Deleted: extra-i686/PKGBUILD
===================================================================
--- extra-i686/PKGBUILD	2014-11-26 13:39:43 UTC (rev 227127)
+++ extra-i686/PKGBUILD	2014-11-26 13:39:45 UTC (rev 227128)
@@ -1,53 +0,0 @@
-# $Id$
-# Maintainer: Felix Yan <felixonmars at gmail.com>
-# Contributor: Thomas Baechler <thomas at archlinux.org>
-
-pkgname=nvidia-304xx
-pkgver=304.123
-_extramodules=extramodules-3.17-ARCH
-pkgrel=9
-pkgdesc="NVIDIA drivers for linux, 304xx legacy branch"
-arch=('i686' 'x86_64')
-url="http://www.nvidia.com/"
-depends=('linux>=3.17' 'linux<3.18' 'nvidia-304xx-libgl' "nvidia-304xx-utils=${pkgver}")
-makedepends=('linux-headers>=3.17' 'linux-headers<3.18')
-conflicts=('nvidia')
-license=('custom')
-install=nvidia.install
-options=(!strip)
-
-if [ "$CARCH" = "i686" ]; then
-    _arch='x86'
-    _pkg="NVIDIA-Linux-${_arch}-${pkgver}"
-    source=("http://us.download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
-    md5sums=('52307054483f5c40391608ce69114d48')
-elif [ "$CARCH" = "x86_64" ]; then
-    _arch='x86_64'
-   _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
-    source=("http://us.download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
-    md5sums=('9d461e9e00e473f458aee96cd6d85101')
-fi
-
-prepare() {
-    cd "${srcdir}"
-    sh "${_pkg}.run" --extract-only
-    cd "${pkg}"
-    # patches here
-}
-
-build() {
-    _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
-    cd "${_pkg}/kernel"
-    make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
-}
-
-package() {
-    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
-        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
-    install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
-    echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
-    sed -i -e "s/EXTRAMODULES='.*'/EXTRAMODULES='${_extramodules}'/" "${startdir}/nvidia.install"
-    gzip "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
-
-    # the license file is part of nvidia-304xx-utils - the module depends on it, so we don't ship it another time.
-}

Copied: nvidia-304xx/repos/extra-i686/PKGBUILD (from rev 227126, nvidia-304xx/repos/testing-i686/PKGBUILD)
===================================================================
--- extra-i686/PKGBUILD	                        (rev 0)
+++ extra-i686/PKGBUILD	2014-11-26 13:39:45 UTC (rev 227128)
@@ -0,0 +1,53 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars at gmail.com>
+# Contributor: Thomas Baechler <thomas at archlinux.org>
+
+pkgname=nvidia-304xx
+pkgver=304.123
+_extramodules=extramodules-3.17-ARCH
+pkgrel=10
+pkgdesc="NVIDIA drivers for linux, 304xx legacy branch"
+arch=('i686' 'x86_64')
+url="http://www.nvidia.com/"
+depends=('linux>=3.17' 'linux<3.18' 'nvidia-304xx-libgl' "nvidia-304xx-utils=${pkgver}")
+makedepends=('linux-headers>=3.17' 'linux-headers<3.18')
+conflicts=('nvidia')
+license=('custom')
+install=nvidia.install
+options=(!strip)
+
+if [ "$CARCH" = "i686" ]; then
+    _arch='x86'
+    _pkg="NVIDIA-Linux-${_arch}-${pkgver}"
+    source=("http://us.download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
+    md5sums=('52307054483f5c40391608ce69114d48')
+elif [ "$CARCH" = "x86_64" ]; then
+    _arch='x86_64'
+   _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
+    source=("http://us.download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
+    md5sums=('9d461e9e00e473f458aee96cd6d85101')
+fi
+
+prepare() {
+    cd "${srcdir}"
+    sh "${_pkg}.run" --extract-only
+    cd "${pkg}"
+    # patches here
+}
+
+build() {
+    _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+    cd "${_pkg}/kernel"
+    make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
+}
+
+package() {
+    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
+        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
+    install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
+    echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
+    sed -i -e "s/EXTRAMODULES='.*'/EXTRAMODULES='${_extramodules}'/" "${startdir}/nvidia.install"
+    gzip "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
+
+    # the license file is part of nvidia-304xx-utils - the module depends on it, so we don't ship it another time.
+}

Deleted: extra-i686/nvidia.install
===================================================================
--- extra-i686/nvidia.install	2014-11-26 13:39:43 UTC (rev 227127)
+++ extra-i686/nvidia.install	2014-11-26 13:39:45 UTC (rev 227128)
@@ -1,15 +0,0 @@
-post_install() {
-    EXTRAMODULES='extramodules-3.17-ARCH'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-    echo 'In order to use nvidia module, reboot the system.'
-}
-
-post_upgrade() {
-    EXTRAMODULES='extramodules-3.17-ARCH'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}
-
-post_remove() {
-    EXTRAMODULES='extramodules-3.17-ARCH'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}

Copied: nvidia-304xx/repos/extra-i686/nvidia.install (from rev 227126, nvidia-304xx/repos/testing-i686/nvidia.install)
===================================================================
--- extra-i686/nvidia.install	                        (rev 0)
+++ extra-i686/nvidia.install	2014-11-26 13:39:45 UTC (rev 227128)
@@ -0,0 +1,15 @@
+post_install() {
+    EXTRAMODULES='extramodules-3.17-ARCH'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+    echo 'In order to use nvidia module, reboot the system.'
+}
+
+post_upgrade() {
+    EXTRAMODULES='extramodules-3.17-ARCH'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}
+
+post_remove() {
+    EXTRAMODULES='extramodules-3.17-ARCH'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}

Deleted: extra-x86_64/PKGBUILD
===================================================================
--- extra-x86_64/PKGBUILD	2014-11-26 13:39:43 UTC (rev 227127)
+++ extra-x86_64/PKGBUILD	2014-11-26 13:39:45 UTC (rev 227128)
@@ -1,53 +0,0 @@
-# $Id$
-# Maintainer: Felix Yan <felixonmars at gmail.com>
-# Contributor: Thomas Baechler <thomas at archlinux.org>
-
-pkgname=nvidia-304xx
-pkgver=304.123
-_extramodules=extramodules-3.17-ARCH
-pkgrel=9
-pkgdesc="NVIDIA drivers for linux, 304xx legacy branch"
-arch=('i686' 'x86_64')
-url="http://www.nvidia.com/"
-depends=('linux>=3.17' 'linux<3.18' 'nvidia-304xx-libgl' "nvidia-304xx-utils=${pkgver}")
-makedepends=('linux-headers>=3.17' 'linux-headers<3.18')
-conflicts=('nvidia')
-license=('custom')
-install=nvidia.install
-options=(!strip)
-
-if [ "$CARCH" = "i686" ]; then
-    _arch='x86'
-    _pkg="NVIDIA-Linux-${_arch}-${pkgver}"
-    source=("http://us.download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
-    md5sums=('52307054483f5c40391608ce69114d48')
-elif [ "$CARCH" = "x86_64" ]; then
-    _arch='x86_64'
-   _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
-    source=("http://us.download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
-    md5sums=('9d461e9e00e473f458aee96cd6d85101')
-fi
-
-prepare() {
-    cd "${srcdir}"
-    sh "${_pkg}.run" --extract-only
-    cd "${pkg}"
-    # patches here
-}
-
-build() {
-    _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
-    cd "${_pkg}/kernel"
-    make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
-}
-
-package() {
-    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
-        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
-    install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
-    echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
-    sed -i -e "s/EXTRAMODULES='.*'/EXTRAMODULES='${_extramodules}'/" "${startdir}/nvidia.install"
-    gzip "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
-
-    # the license file is part of nvidia-304xx-utils - the module depends on it, so we don't ship it another time.
-}

Copied: nvidia-304xx/repos/extra-x86_64/PKGBUILD (from rev 227126, nvidia-304xx/repos/testing-x86_64/PKGBUILD)
===================================================================
--- extra-x86_64/PKGBUILD	                        (rev 0)
+++ extra-x86_64/PKGBUILD	2014-11-26 13:39:45 UTC (rev 227128)
@@ -0,0 +1,53 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars at gmail.com>
+# Contributor: Thomas Baechler <thomas at archlinux.org>
+
+pkgname=nvidia-304xx
+pkgver=304.123
+_extramodules=extramodules-3.17-ARCH
+pkgrel=10
+pkgdesc="NVIDIA drivers for linux, 304xx legacy branch"
+arch=('i686' 'x86_64')
+url="http://www.nvidia.com/"
+depends=('linux>=3.17' 'linux<3.18' 'nvidia-304xx-libgl' "nvidia-304xx-utils=${pkgver}")
+makedepends=('linux-headers>=3.17' 'linux-headers<3.18')
+conflicts=('nvidia')
+license=('custom')
+install=nvidia.install
+options=(!strip)
+
+if [ "$CARCH" = "i686" ]; then
+    _arch='x86'
+    _pkg="NVIDIA-Linux-${_arch}-${pkgver}"
+    source=("http://us.download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
+    md5sums=('52307054483f5c40391608ce69114d48')
+elif [ "$CARCH" = "x86_64" ]; then
+    _arch='x86_64'
+   _pkg="NVIDIA-Linux-${_arch}-${pkgver}-no-compat32"
+    source=("http://us.download.nvidia.com/XFree86/Linux-${_arch}/${pkgver}/${_pkg}.run")
+    md5sums=('9d461e9e00e473f458aee96cd6d85101')
+fi
+
+prepare() {
+    cd "${srcdir}"
+    sh "${_pkg}.run" --extract-only
+    cd "${pkg}"
+    # patches here
+}
+
+build() {
+    _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+    cd "${_pkg}/kernel"
+    make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
+}
+
+package() {
+    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
+        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
+    install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
+    echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
+    sed -i -e "s/EXTRAMODULES='.*'/EXTRAMODULES='${_extramodules}'/" "${startdir}/nvidia.install"
+    gzip "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
+
+    # the license file is part of nvidia-304xx-utils - the module depends on it, so we don't ship it another time.
+}

Deleted: extra-x86_64/nvidia.install
===================================================================
--- extra-x86_64/nvidia.install	2014-11-26 13:39:43 UTC (rev 227127)
+++ extra-x86_64/nvidia.install	2014-11-26 13:39:45 UTC (rev 227128)
@@ -1,15 +0,0 @@
-post_install() {
-    EXTRAMODULES='extramodules-3.17-ARCH'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-    echo 'In order to use nvidia module, reboot the system.'
-}
-
-post_upgrade() {
-    EXTRAMODULES='extramodules-3.17-ARCH'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}
-
-post_remove() {
-    EXTRAMODULES='extramodules-3.17-ARCH'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}

Copied: nvidia-304xx/repos/extra-x86_64/nvidia.install (from rev 227126, nvidia-304xx/repos/testing-x86_64/nvidia.install)
===================================================================
--- extra-x86_64/nvidia.install	                        (rev 0)
+++ extra-x86_64/nvidia.install	2014-11-26 13:39:45 UTC (rev 227128)
@@ -0,0 +1,15 @@
+post_install() {
+    EXTRAMODULES='extramodules-3.17-ARCH'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+    echo 'In order to use nvidia module, reboot the system.'
+}
+
+post_upgrade() {
+    EXTRAMODULES='extramodules-3.17-ARCH'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}
+
+post_remove() {
+    EXTRAMODULES='extramodules-3.17-ARCH'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}


More information about the arch-commits mailing list