[arch-commits] Commit in nvidia/repos (10 files)

Tobias Powalowski tpowa at archlinux.org
Wed Nov 26 13:39:47 UTC 2014


    Date: Wednesday, November 26, 2014 @ 14:39:47
  Author: tpowa
Revision: 227129

db-move: moved nvidia from [testing] to [extra] (i686, x86_64)

Added:
  nvidia/repos/extra-i686/PKGBUILD
    (from rev 227126, nvidia/repos/testing-i686/PKGBUILD)
  nvidia/repos/extra-i686/nvidia.install
    (from rev 227126, nvidia/repos/testing-i686/nvidia.install)
  nvidia/repos/extra-x86_64/PKGBUILD
    (from rev 227126, nvidia/repos/testing-x86_64/PKGBUILD)
  nvidia/repos/extra-x86_64/nvidia.install
    (from rev 227126, nvidia/repos/testing-x86_64/nvidia.install)
Deleted:
  nvidia/repos/extra-i686/PKGBUILD
  nvidia/repos/extra-i686/nvidia.install
  nvidia/repos/extra-x86_64/PKGBUILD
  nvidia/repos/extra-x86_64/nvidia.install
  nvidia/repos/testing-i686/
  nvidia/repos/testing-x86_64/

-----------------------------+
 /PKGBUILD                   |   94 ++++++++++++++++++++++++++++++++++++++++++
 /nvidia.install             |   36 ++++++++++++++++
 extra-i686/PKGBUILD         |   47 ---------------------
 extra-i686/nvidia.install   |   18 --------
 extra-x86_64/PKGBUILD       |   47 ---------------------
 extra-x86_64/nvidia.install |   18 --------
 6 files changed, 130 insertions(+), 130 deletions(-)

Deleted: extra-i686/PKGBUILD
===================================================================
--- extra-i686/PKGBUILD	2014-11-26 13:39:45 UTC (rev 227128)
+++ extra-i686/PKGBUILD	2014-11-26 13:39:47 UTC (rev 227129)
@@ -1,47 +0,0 @@
-# $Id$
-# Maintainer : Thomas Baechler <thomas at archlinux.org>
-
-pkgname=nvidia
-pkgver=343.22
-_extramodules=extramodules-3.17-ARCH
-pkgrel=4
-pkgdesc="NVIDIA drivers for linux"
-arch=('i686' 'x86_64')
-url="http://www.nvidia.com/"
-depends=('linux>=3.17' 'linux<3.18' "nvidia-libgl" "nvidia-utils=${pkgver}")
-makedepends=('linux-headers>=3.17' 'linux-headers<3.18')
-license=('custom')
-install=nvidia.install
-options=(!strip)
-source=("ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run"
-        "ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-md5sums=('696d0bfa7195e22e0c4bd858fff2abb6'
-         '3d98eaa01a94e86abb04723ae2a702b1')
-
-[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
-[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
-
-prepare() {
-    sh "${_pkg}.run" --extract-only
-    cd "${_pkg}"
-    # patches here
-}
-
-build() {
-    _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
-    cd "${_pkg}"/kernel
-    make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
-
-    cd uvm
-    make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
-}
-
-package() {
-    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
-        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
-    install -D -m644 "${srcdir}/${_pkg}/kernel/uvm/nvidia-uvm.ko" \
-        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-uvm.ko"
-    gzip "${pkgdir}/usr/lib/modules/${_extramodules}/"*.ko
-    install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
-    echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
-}

Copied: nvidia/repos/extra-i686/PKGBUILD (from rev 227126, nvidia/repos/testing-i686/PKGBUILD)
===================================================================
--- extra-i686/PKGBUILD	                        (rev 0)
+++ extra-i686/PKGBUILD	2014-11-26 13:39:47 UTC (rev 227129)
@@ -0,0 +1,47 @@
+# $Id$
+# Maintainer : Thomas Baechler <thomas at archlinux.org>
+
+pkgname=nvidia
+pkgver=343.22
+_extramodules=extramodules-3.17-ARCH
+pkgrel=5
+pkgdesc="NVIDIA drivers for linux"
+arch=('i686' 'x86_64')
+url="http://www.nvidia.com/"
+depends=('linux>=3.17' 'linux<3.18' "nvidia-libgl" "nvidia-utils=${pkgver}")
+makedepends=('linux-headers>=3.17' 'linux-headers<3.18')
+license=('custom')
+install=nvidia.install
+options=(!strip)
+source=("ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run"
+        "ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
+md5sums=('696d0bfa7195e22e0c4bd858fff2abb6'
+         '3d98eaa01a94e86abb04723ae2a702b1')
+
+[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
+[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
+
+prepare() {
+    sh "${_pkg}.run" --extract-only
+    cd "${_pkg}"
+    # patches here
+}
+
+build() {
+    _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+    cd "${_pkg}"/kernel
+    make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
+
+    cd uvm
+    make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
+}
+
+package() {
+    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
+        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
+    install -D -m644 "${srcdir}/${_pkg}/kernel/uvm/nvidia-uvm.ko" \
+        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-uvm.ko"
+    gzip "${pkgdir}/usr/lib/modules/${_extramodules}/"*.ko
+    install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
+    echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
+}

Deleted: extra-i686/nvidia.install
===================================================================
--- extra-i686/nvidia.install	2014-11-26 13:39:45 UTC (rev 227128)
+++ extra-i686/nvidia.install	2014-11-26 13:39:47 UTC (rev 227129)
@@ -1,18 +0,0 @@
-post_install() {
-    EXTRAMODULES='extramodules-3.17-ARCH'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-    echo 'In order to use nvidia module, reboot the system.'
-}
-
-post_upgrade() {
-    EXTRAMODULES='extramodules-3.17-ARCH'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-    if  [ "$(vercmp $2 310.19-2)" -lt 0 ]; then
-        echo 'If your card is from the 7xxx series or earlier, install nvidia-304xx'
-    fi
-}
-
-post_remove() {
-    EXTRAMODULES='extramodules-3.17-ARCH'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}

Copied: nvidia/repos/extra-i686/nvidia.install (from rev 227126, nvidia/repos/testing-i686/nvidia.install)
===================================================================
--- extra-i686/nvidia.install	                        (rev 0)
+++ extra-i686/nvidia.install	2014-11-26 13:39:47 UTC (rev 227129)
@@ -0,0 +1,18 @@
+post_install() {
+    EXTRAMODULES='extramodules-3.17-ARCH'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+    echo 'In order to use nvidia module, reboot the system.'
+}
+
+post_upgrade() {
+    EXTRAMODULES='extramodules-3.17-ARCH'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+    if  [ "$(vercmp $2 310.19-2)" -lt 0 ]; then
+        echo 'If your card is from the 7xxx series or earlier, install nvidia-304xx'
+    fi
+}
+
+post_remove() {
+    EXTRAMODULES='extramodules-3.17-ARCH'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}

Deleted: extra-x86_64/PKGBUILD
===================================================================
--- extra-x86_64/PKGBUILD	2014-11-26 13:39:45 UTC (rev 227128)
+++ extra-x86_64/PKGBUILD	2014-11-26 13:39:47 UTC (rev 227129)
@@ -1,47 +0,0 @@
-# $Id$
-# Maintainer : Thomas Baechler <thomas at archlinux.org>
-
-pkgname=nvidia
-pkgver=343.22
-_extramodules=extramodules-3.17-ARCH
-pkgrel=4
-pkgdesc="NVIDIA drivers for linux"
-arch=('i686' 'x86_64')
-url="http://www.nvidia.com/"
-depends=('linux>=3.17' 'linux<3.18' "nvidia-libgl" "nvidia-utils=${pkgver}")
-makedepends=('linux-headers>=3.17' 'linux-headers<3.18')
-license=('custom')
-install=nvidia.install
-options=(!strip)
-source=("ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run"
-        "ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-md5sums=('696d0bfa7195e22e0c4bd858fff2abb6'
-         '3d98eaa01a94e86abb04723ae2a702b1')
-
-[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
-[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
-
-prepare() {
-    sh "${_pkg}.run" --extract-only
-    cd "${_pkg}"
-    # patches here
-}
-
-build() {
-    _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
-    cd "${_pkg}"/kernel
-    make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
-
-    cd uvm
-    make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
-}
-
-package() {
-    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
-        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
-    install -D -m644 "${srcdir}/${_pkg}/kernel/uvm/nvidia-uvm.ko" \
-        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-uvm.ko"
-    gzip "${pkgdir}/usr/lib/modules/${_extramodules}/"*.ko
-    install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
-    echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
-}

Copied: nvidia/repos/extra-x86_64/PKGBUILD (from rev 227126, nvidia/repos/testing-x86_64/PKGBUILD)
===================================================================
--- extra-x86_64/PKGBUILD	                        (rev 0)
+++ extra-x86_64/PKGBUILD	2014-11-26 13:39:47 UTC (rev 227129)
@@ -0,0 +1,47 @@
+# $Id$
+# Maintainer : Thomas Baechler <thomas at archlinux.org>
+
+pkgname=nvidia
+pkgver=343.22
+_extramodules=extramodules-3.17-ARCH
+pkgrel=5
+pkgdesc="NVIDIA drivers for linux"
+arch=('i686' 'x86_64')
+url="http://www.nvidia.com/"
+depends=('linux>=3.17' 'linux<3.18' "nvidia-libgl" "nvidia-utils=${pkgver}")
+makedepends=('linux-headers>=3.17' 'linux-headers<3.18')
+license=('custom')
+install=nvidia.install
+options=(!strip)
+source=("ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run"
+        "ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
+md5sums=('696d0bfa7195e22e0c4bd858fff2abb6'
+         '3d98eaa01a94e86abb04723ae2a702b1')
+
+[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
+[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
+
+prepare() {
+    sh "${_pkg}.run" --extract-only
+    cd "${_pkg}"
+    # patches here
+}
+
+build() {
+    _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+    cd "${_pkg}"/kernel
+    make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
+
+    cd uvm
+    make SYSSRC=/usr/lib/modules/"${_kernver}/build" module
+}
+
+package() {
+    install -D -m644 "${srcdir}/${_pkg}/kernel/nvidia.ko" \
+        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia.ko"
+    install -D -m644 "${srcdir}/${_pkg}/kernel/uvm/nvidia-uvm.ko" \
+        "${pkgdir}/usr/lib/modules/${_extramodules}/nvidia-uvm.ko"
+    gzip "${pkgdir}/usr/lib/modules/${_extramodules}/"*.ko
+    install -d -m755 "${pkgdir}/usr/lib/modprobe.d"
+    echo "blacklist nouveau" >> "${pkgdir}/usr/lib/modprobe.d/nvidia.conf"
+}

Deleted: extra-x86_64/nvidia.install
===================================================================
--- extra-x86_64/nvidia.install	2014-11-26 13:39:45 UTC (rev 227128)
+++ extra-x86_64/nvidia.install	2014-11-26 13:39:47 UTC (rev 227129)
@@ -1,18 +0,0 @@
-post_install() {
-    EXTRAMODULES='extramodules-3.17-ARCH'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-    echo 'In order to use nvidia module, reboot the system.'
-}
-
-post_upgrade() {
-    EXTRAMODULES='extramodules-3.17-ARCH'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-    if  [ "$(vercmp $2 310.19-2)" -lt 0 ]; then
-        echo 'If your card is from the 7xxx series or earlier, install nvidia-304xx'
-    fi
-}
-
-post_remove() {
-    EXTRAMODULES='extramodules-3.17-ARCH'
-    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
-}

Copied: nvidia/repos/extra-x86_64/nvidia.install (from rev 227126, nvidia/repos/testing-x86_64/nvidia.install)
===================================================================
--- extra-x86_64/nvidia.install	                        (rev 0)
+++ extra-x86_64/nvidia.install	2014-11-26 13:39:47 UTC (rev 227129)
@@ -0,0 +1,18 @@
+post_install() {
+    EXTRAMODULES='extramodules-3.17-ARCH'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+    echo 'In order to use nvidia module, reboot the system.'
+}
+
+post_upgrade() {
+    EXTRAMODULES='extramodules-3.17-ARCH'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+    if  [ "$(vercmp $2 310.19-2)" -lt 0 ]; then
+        echo 'If your card is from the 7xxx series or earlier, install nvidia-304xx'
+    fi
+}
+
+post_remove() {
+    EXTRAMODULES='extramodules-3.17-ARCH'
+    depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
+}


More information about the arch-commits mailing list