[arch-commits] Commit in qt6-5compat/repos/kde-unstable-x86_64 (PKGBUILD PKGBUILD)

Antonio Rojas arojas at archlinux.org
Mon Nov 16 11:41:47 UTC 2020


    Date: Monday, November 16, 2020 @ 11:41:47
  Author: arojas
Revision: 401268

archrelease: copy kde-unstable to kde-unstable-x86_64

Added:
  qt6-5compat/repos/kde-unstable-x86_64/PKGBUILD
    (from rev 401267, qt6-5compat/kde-unstable/PKGBUILD)
Deleted:
  qt6-5compat/repos/kde-unstable-x86_64/PKGBUILD

----------+
 PKGBUILD |   60 ++++++++++++++++++++++++++++++------------------------------
 1 file changed, 30 insertions(+), 30 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2020-11-16 11:41:39 UTC (rev 401267)
+++ PKGBUILD	2020-11-16 11:41:47 UTC (rev 401268)
@@ -1,30 +0,0 @@
-# Maintainer: Antonio Rojas <arojas at archlinux.org>
-# Maintainer: Felix Yan <felixonmars at archlinux.org>
-# Contributor: Andrea Scarpino <andrea at archlinux.org>
-
-pkgname=qt6-5compat
-_qtver=6.0.0-beta4
-pkgver=${_qtver/-/}
-pkgrel=1
-arch=(x86_64)
-url='https://www.qt.io'
-license=(GPL3 LGPL3 FDL custom)
-pkgdesc='Module that contains unsupported Qt 5 APIs'
-depends=(qt6-base)
-makedepends=(cmake)
-groups=(qt6)
-_pkgfn="${pkgname/6-/}-everywhere-src-${_qtver}"
-source=("https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz")
-sha256sums=('3d453b278fd44290bda3d688b7699e0f243675517b3c3109aa4ee0be6cf8e81d')
-
-build() {
-  cmake -B build -S $_pkgfn
-  cmake --build build
-}
-
-package() {
-  DESTDIR="$pkgdir" cmake --install build
-
-  install -d "$pkgdir"/usr/share/licenses
-  ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname
-}

Copied: qt6-5compat/repos/kde-unstable-x86_64/PKGBUILD (from rev 401267, qt6-5compat/kde-unstable/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2020-11-16 11:41:47 UTC (rev 401268)
@@ -0,0 +1,30 @@
+# Maintainer: Antonio Rojas <arojas at archlinux.org>
+# Maintainer: Felix Yan <felixonmars at archlinux.org>
+# Contributor: Andrea Scarpino <andrea at archlinux.org>
+
+pkgname=qt6-5compat
+_qtver=6.0.0-beta5
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(x86_64)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Module that contains unsupported Qt 5 APIs'
+depends=(qt6-base)
+makedepends=(cmake)
+groups=(qt6)
+_pkgfn="${pkgname/6-/}-everywhere-src-${_qtver}"
+source=("https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz")
+sha256sums=('e40cdc2c107b34c38e09dc69961f57d3ba703eba4ac56ffc9f63daef34eb6881')
+
+build() {
+  cmake -B build -S $_pkgfn
+  cmake --build build
+}
+
+package() {
+  DESTDIR="$pkgdir" cmake --install build
+
+  install -d "$pkgdir"/usr/share/licenses
+  ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname
+}


More information about the arch-commits mailing list