[arch-dev-public] Updating gcc3 package

Jan de Groot jan at jgc.homeip.net
Wed Jun 20 03:26:46 EDT 2007

Think about this:
Gcc 4.x is on the same ABI as gcc 3.4, there's lots of file conflicts in
that and you'll end up using gcc 4.2 libraries with a gcc 3.4 compiler. Gcc
3.3 is the last released version of the previous C++ ABI and is still
maintained AFAIK. A package that requires gcc 3.4 to compile (nothing newer,
nothing older) is so broken that upstream should fix it, we shouldn't even
bother about it. Even OpenOffice.org got this point improved in the last two

-----Oorspronkelijk bericht-----
Van: arch-dev-public-bounces at archlinux.org
[mailto:arch-dev-public-bounces at archlinux.org] Namens Jason Chu
Verzonden: dinsdag 19 juni 2007 23:30
Aan: arch-dev-public at archlinux.org
Onderwerp: [arch-dev-public] Updating gcc3 package

Does anyone have any problems with me updating the gcc3 package to gcc3.4?
It looks like the only packages that depend on it in extra are qemu and

Like tpowa said, kvm doesn't compile with gcc 3.3 but will with gcc 3.4.
It seems that qemu doesn't care, just as long as it's not gcc 4.

Do any packages depend on gcc 3.3?


More information about the arch-dev-public mailing list